Unwanted blinking in particle emitter


I came across this issue:

Was changing other emitter’s Dynamic parameters, when this started happening to those emitters that have their Dynamic parameters disabled(don’t need them for those). It’s a same Material, though.

Everything else seems to be in order…Not sure where to even look for for the solution. It almost started happening randomly. I even tried turning on/off UE4 :smiley: just IN CASE. (Didn’t help)

I think your particle is disappearing, it’s not visible and then new one is spawning. This can cause this effect. Try to set lifetime to 2 sec (for test) and see if that helps.

Hmm, unfortunately. I tried. It also is 1 particke burst.
I’ve disabled basically almost everything and the thing blinks:


What are spawn rate and lifetime settings? (Try changing them to high values eg lifetime to 10 sec and spawn to 10)

Here is working sample that is not blinking (Lifetime set to 1 sec and spawn rate to 10). It’s not blinking even on lowest settings.

(Just coppy and paste to your project directory.)

You may also consider to use niagara instead of old particle system. But it depends on what are you trying to achieve.

Hope that helps.