Unstable physics


In my game there are many blueprints that simulate physics. I build some constructions out of those blueprints. They usually behave quite stable-the bodies don’t fall over weirdly.

But now I came up with an idea to add a special animation-I want all the blueprints to move out of the level, so i have room to perform some actions, and when I’m done, I’d like the blueprints to return to exact same configuration. So basically what I do is:

  1. In for-each loop, I store the references to the blueprints of given class and their origin locations plus I calculate the destinations of them(for animation purposes), I “SetSimulatePhysics” for them to false
  2. I linearly interpolate from origin to destination(by modyfing root component’s World Location)
  3. I do stuff (doesn’t matter what exactly)
  4. I linearly interpolate in reverse-from former destination to origin(I clamp the lerp param to range 0-1 so it’s certain that the final position is exactly the same as original)
  5. I turn the physics simulation back on

The problem is that after the blueprints return, the physics for them seems broken:

I circled one brick to show the exact problem-the bricks don’t collide with each other. That brick just fell through the pillars.

Note: when I skip the interpolation steps(so basically, I don’t modify the location) everything seems fine after turning simulation back on.
I tried reawakening the bodies or putting them to sleep, but it didn’t work. I also tried setting linear/angular velocities to (0,0,0), but didn’t help either.

What’s the reason of that weird behavior, how to solve the problem? Is that a bug?

It’s been a week and there’s no response. Doesn’t anyone know any possible reason of that issue?

okay, that still happens in 4.6, can I receive any help with that?