Unresolved compile Error (while there is no Error)

I have one blueprint which I can’t compile to get it “clean”, it’s always “dirty” after compiling, but it does not give any errors on compile. It’s just dirty. So that’s not too awful since I can just ignore it and everything works.

The annoying thing is that every time I want to play my game this screen appears:

http://puu.sh/gDrRB/39fa8db6ca.png

So I hit “play”, have to wait ~15 seconds while the engine does whatever (I have compiling on hitting play disabled, so I really have no idea why I have to wait so long after hitting play) and then I have to click on “yes” to be able to start my game.

So I either want to be able to disable error checks for this particular blueprint or, even better, like to have the “always dirty” stuff fixed.

Is this a known problem? I have this issue since version 4.6. At the moment I use the most recent 4.7 branch from today.

Hi John,

A dirty asset is one that hasn’t been saved, and doesn’t have anything to do with compiling. A Blueprint with a compile error can still be saved and it won’t display as dirty. If you’re updating a Blueprint or one of its references, it’ll be marked dirty immediately. Save All should take care of that.

Is your MiningBuilding in the level? If so, and it’s failing to compile, this error is going to come up every time. There currently isn’t a way to bypass this message. Can I take a look at the graph for the BP in question? If it’s not failing to compile but you’re getting this message, something is going wrong and I’d like to see what. If you have the BP open when you hit Play, and you can see that it’s been compiled, does it switch to a compile error when you hit PIE?

Another person has reported a similar issue in 4.7.2, so I have one more question: do you have any variables in this BP that are accessed in other BPs (or vice versa) that are not marked Public?

I always save all and it never had any effects on whether a blueprint is marked as dirty or not, “Dirty, needs to be recompiled” appears if I hover over the compile button of a blueprint which is not compiled, if I compile it there is usually written “Good to go”.

I don’t have any MiningBuilding or any of it childs in my level.
I actually have some quiet big functions in there which don’t fit on one screenshot.

What exactly is “hitting PIE”?

Most variables in “MiningBuilding” are just the variables from the parent class “Building”. Apart from this I have 3 variables and if I all mark them public this doesn’t change anything. MiningBuilding is not accessing any variables from other blueprints.

PIE = Play In Editor. Sorry, it’s a term I sometimes forget not everyone is familiar with.

I think I’ve found the problem with this post, and I believe it’s related to your issue:

After you hit Yes to compile the Blueprints at Play, if you PIE again, do you get the same message? Do you ever get one that mentions a PROTO Blueprint that needs compiling?

aah, play in editor, I should have known that :slight_smile:

After I hit yes to continue play even with this “compile error”, stop the game and hit play again I get the same message. I always get it.

I can not remember ever getting any message which said something about “PROTO”.

Actually I wonder why I have not get any notification about your answer here… I have subscribed this post as usual but I didn’t get any mail about your answer.

Okay, I entered a bug report for that other post (UE-12038), but I’m not 100% sure it’s related. I’m going to check in with the devs and see what they think, and get back to you as soon as I hear from them. Thanks for your patience!

Not sure why you’re not getting notifications about this post. Sometimes weird things happen with AnswerHub. Try unsubscribing/resubscribing and see if that helps.

One last question: you said MiningBuilding is not in the level. Is it being spawned at any point, or is it otherwise referenced by something in the level?

Since my game is a RTS, there is about nothing in the level, the player has to place everything :slight_smile: After the game runs I can select and spawn it, but before that there is nothing in the level which could reference a MiningBuilding.

Hm. And it’s compiled successfully before you begin play?

If I hit compile I get

Info [5958.86] Compile of MiningBuilding successful! [in 782 ms]

It just always stays dirty.

34651-dirty.gif

That’s very strange. I didn’t realize it was still saying Compile after clicking the button. So the log says it’s successful, but the BP still wants to be compiled. I’ll mention that to the devs as well. Thanks!

Okay, I spoke with the developers and it sounds like there is a known bug where Blueprints that depend on each other will cyclically mark the other dirty, and that’s probably what’s happening here. This results in a UI bug where a blueprint can appear to be perpetually dirty (but it is just a UI bug). They’re working to fix that.

They wanted to check: If you turn Auto Recompile Blueprints back on, does this warning go away? It’s possible they need to stop marking things dirty in these situations if this option is turned off.

I usually had auto recompile blueprint on, I always get the message that there is an error in mining building, no matter whether auto recompile is on or off.

Okay, can I get a copy of your project? If we can reproduce it here we should be able to figure out what’s going on.

Sure, I will zip and upload my project and send you the link in the forums.

Hi John,

I was able to reproduce this behavior with the MiningBuilding Blueprint in 4.7.3, and I’ve entered a bug report for the issue (UE-12129). I included a copy of the project so the developers have something to work with. I’ll let you know as soon as I see any update on it. For now, it doesn’t appear to be causing any issues during PIE, so you should be able to work around it (aside from the mild annoyance of having to click the Yes button before PIE every time).

I also checked this in 4.8, and compiling the same Blueprint crashed the editor. I’ve included that information in the bug report, but I wanted to make sure you’re aware of it. Hopefully fixing one issue will also fix the other.

I’m not sure what’s causing a long compile time for you, though. It’s definitely doing something, but I’m only getting a few seconds delay at most. You might try removing the Intermediate and Saved folders from your project (make a copy somewhere, first!).

Hi John,

Just letting you know that this has been fixed internally, and the fix should appear in 4.8. If you test a copy of your project in 4.8 Preview 2 and this still occurs, please let us know. Thanks!

UE-12129 is not in the “Fixed Bugs” list of 4.8P2. Are you sure it’s in the Preview 2?

I just tested it in P2 and didn’t have any trouble compiling the MiningBuilding BP.