[Unreal4.10]On Distribution Build Provision and Signing key not found

Hello there,

This is the second self published iOS game I’m working on, first on Unreal4.10

I have followed the process to add the provision, and certificates as advised. Both are Status Valid, and the Provision is check marked for distribution. However, I’m getting this error whenever I try to build a Distribution iOS package(file or whatever it maybe called)

The correct Provision, and Certificate is check marked in the Platforms - iOS Project Settings like it should be.

Any help would be great.

Update: I tried the same provision and certificates on a 4.9 Build and it works fine. So this must be an issue with 4.10. I unfortunately can’t revert my 4.10 project however. Which means I’m stuck until this is fixed :(.

I don’t have this problem when building, however, when uploaded to the itunesconnect via application loader, i’m getting an email that my build has an invalid signature thus making it an invalid binaries. This happens in 4.10 build only.

Now, using 4.9.3 build, using the same cert and prov, I’m able to upload and test it on testflight.

However, itunesconnect sux, i’m unable to save any changes, and stuck in prepare for submission… for more than a month… damnt

Yeah it’s weird, after trying multiple times before testing on 4.9… On 4.10 I was able to get one of the errors removed. Then I redid the process, again, and the second error came up. Looks like the build process to iOS is super Fubar atm.

I’ve added it as a Bug on Answer Hub as I have the same problem. Feel free to bump it or add more info

rOb

Thanks Rob, appreciated it.

I added my bug to Answer Hub as well. As mine is a little bit different.

https://answers.unrealengine.com/questions/339598/unreal410on-distribution-build-provision-and-signi.html

Please read the response to this post from Peter Sauerbrei

I feel like the issue I originally posted has not been addressed by any party. It also sounds as if it is something different. I was able to build a project in 4.9 and submit just fine, I did so yesterday. 4.10 builds do not work however. So the problem doesn’t seem to do with Apple at this time.

Edit: I did submit my files to Apple, but have not heard a response just yet. So it could still be possible that they will reject it.

I had the issue with the certs / key not found. I removed all the .cer and .mobile provisions from my PC, rebooted, then reimported them again. I still got the same cert / key error until I added my dev cert / provision back in too. I didn’t tick any of the certs or provisions , my dev cert and provision highlighted in green. Now if I go into packaging and select shipping / distribution it packages using the distribution profile and cert, pretty much the same as in 4.9 … of course now we hit the problem with Apple rejecting due to Apple changing the way the signing is done, see the bug on answer Hub in the link above.

Massive thanks Steve and Pete at Epic for the quick response to this, hopefully the fix will be a simple one, in the meantime I’ll have to package on my poor mac mini :slight_smile:

rOb

Thanks. That’s explain quit a bit. But I’m sticking with 4.9.3 for now, by packaging the app using the iOS SDK in it, will it effect my app submissions/review in iTunesConnect?

I noticed that, when I select a build for submission, the icon does not shows at all after selected, thou from the pop-up build selection it does show the icon.

This problem will affect any distribution package generated from any windows version of UE4, Apple will reject it ; Apple have altered the information needed in the signing of the .ipa files. You will either have to wait for Epic to make the changes to the Windows version of the Editor or use a Mac.

rOb

Thanks Rob

Update: My project update in 4.9.2 was approved on Monday from Apple. This was with a purely blueprint project. So I’m not sure it’s Apple that is causing my break.

Hi Bpop, that’s a great news for you, I would guess my 4.9.2 blueprint based game would be accepted too, maybe for an app using older SDK, signing it in Windows really does not matter, compare to using newest SDK - the signing must be done in Apple based machines.

Hey, btw Bpop, care to share what are you releasing in AppStore?

Goodluck :slight_smile: Tell us if it gets approved.

I just created a Tappy Chicken clone but with much tighter mechanics and unique assets. It’s called Tap Happy Unicorn. I used it as a learning process to what is required to submit a game. Including shared leaderboards, achievements, Ad support, and whatnot. Was a real fun experience. I have about 3 other games I’m working on, one already finished and waiting for testing before submission. But can’t since I’m using 4.10.1 for the next 3 :(.

Still no help for the blueprint only projects in 4.10.1. Getting very discouraged and not sure if Unreal is even taking a look at it.

I made a new post in the Bug section [4.10]Unable to Build to iOS in 4.10. But same Provision and Signing keys work in 4.9 - Mobile - Unreal Engine Forums

But in my previous answerhub question has identified a few other people who are experiencing the same thing. [Unreal4.10]On Distribution Build Provision and Signing key not found - Mobile - Unreal Engine Forums

Any help would be greatly appreciated.

-Brandon

Hey, I’ve been building in 4.10.1 and I’ve been getting this error too. However, I’ve had no issue uploading to the AppStore through Application Loader and at the very least allowing people to test through TestFlight is fine!

The error I’m receiving causes the build to fail. And not creating a file to upload using application loader. Are you using a mac to build? Or how do you get around the build failing?

I’m looking at your other post and not sure exactly what you are doing. Could you please provide a step by step on how you were able to create the .ipa. I don’t see anywhere in iPhone Packager where that is possible. Any help would be greatly appreciated.