Download

Unreal white flickering problem (its not an auto exposure problem)

Hi, I’m having a problem with a flickering screen (see the YouTube link).
I have set the engine scalability of post-processing to high and then noticed this happening.
I tried turning off auto exposure, didn’t work.
I tried to isolate a room within the level by walls and paid attention that there was no light what so ever shining into the room and the problem still persisted.
I tried to set the post process min and max to both 1, that didn’t work either.
I tried to recreate the problem in another first person template but it did not work.
I tried to solve it by deleting any kind of fog and/or emitter but it didn’t work.

The only “solution” I found so far is to turn off anti-aliasing or set it to medium in the settings. But that is definitely not satisfactory and I’d like to know whether anyone knows what is causing it and how to solve it.

And the main problem is that it is also occurring in the build.

Does anyone have a solution for that?
I don’t know if it is relevant but I am using 4.24.

There you can see the problem:
https://youtu.be/rwjDAHMoT3E

Greetings

It appeared to be worse when viewing from a dark, shadowed area. Is Temporal Upsampling enabled in Project settings? Try disabling it, if yes. It almost looks like lighting that is trying to get rendered in the scene, but isn’t completing. What are the main lights’ settings (directional and skylight)?

I just checked and TemporalUpsampling is disabled.
There is no SkyLight in my Scene. Only the Skysphere and two directional lights. The directional light actor of the skysphere is directional light 2.
I have deleted the directional lights and the skysphere to check whether anything changes with the problem, but nothing happened.

Looks like it’s related to volumetric fog. Do you have a light attached to the player/camera?

I deleted the volumetric fog and don’t have a light attached.

What is the fog setup from the video? If it’s the volumetric fog you deleted, then I think something is happening with the lighting for the darker areas. Whenever the darker areas occupy more of the camera view than the lighter areas (in the middle areas of the room it’s lighter), the flickering happens more. What are the material graphs of the walls / floor / ceiling (including general properties that are visible in the material editor after clicking in an empty part of the grid)?

I get the same thing in pretty much any project I create. The only solution I’ve found has been to disable bloom, it’s an engine bug and it’s making it difficult to want to use UE4.

Thank you very much for your help. The solution was indeed to disable bloom.

Try setting Bloom Threshold greater than zero instead of disabling it completely