Download

Unreal Sound Loss

Hello Guys.

I’m not sure it happend only my case. Anyway. I setting up sound(music) in level without attenation(no occlusion, no reverb. It’s 2D sound, Compression Quality is 100, Sound class is default also). However, there’s difference between original source and engines’ output. I think there’s not only frequency differneces but also stereo images(it sounds like more narrow). Also, original source’s loudness(LUFS) is about -5~6, but engine’s output is about -10~11. I compared two sources in Protools and used Izotope insight.

Do you guys know how to solve or had experienced similar problem?

Show some screen shots of the original vs. UE4 in a side by side comparison please. How did you get the audio output from UE4 into Protools? did you record the output into Protools or did you export the .wav file out of UE4? Are there any differences in the file format for the original vs. UE4 (i.e. sample rate, bit depth, etc…). Show some images of your UE4 set-up if you can too, just in case you’ve missed something…

Thank you for your reply.

I uploded some of pictures. One is original sound.
9ebe246e38f8b2a0f19406f1ce654c8c76c9947d.jpeg
The other is same source that is from Unreal output. I can see about -2db head room on Unreal output.
c08ec634857708fb264e6ce0743765584a6ebf1b.jpeg

Sourece is 44100, 16bit. I set up Audio sample rate 44100 too.

I cannot upload sound file in this page(page said I’m not allowed upload sound file) but you can see the Izotope RX picture. I can see the some of loss(first one is Original)
[ATTACH=JSON]{“data-align”:“none”,“data-size”:“medium”,“data-tempid”:“temp_139487_1528192358546_481”}[/ATTACH]

please help me T.T

I’ll run some tests myself tonight and see what I can find.

That is the best quality of an ogg audio. It is lossy. Mostly in the mid / high frequency domain you will notice some differences.

You can perhaps try a -3 or 0 db, depending on your audio content. This provides you better quality either way.

That’s set for compatibility reasons, you will find the -3db setting in the Config/Windows/WindowsEngine.ini (or mac/macengine.ini)

Yes i’ve had strange issues with 44k audio, but since i use 48k everything seems ok. Not sure about the stereo image problem tho, it could be related to the ogg vorbis implementation in engine.

I posted about this a few weeks ago.

https://forums.unrealengine.com/deve…uced-on-import

It’s very noticeable, and doesn’t sound like it’s solely compression. I actually reported this as a bug, and heard back from Epic QA. I’ve attached the email conversation below.


Haven’t heard back since that last email. Don’t know what else to do from here.

MP3 in my experiences sounds worse compared to ogg. There are however many profile settings comes for both codecs, which settings are not exposed to the engine as youcan see. You can either find ways to modify the codec behavior and turn it to your requirements (eg, change the stereo mixdown to avoid the use of m/s joint-stereo?) , or you can move to more ‘expensive’ solutions such as wwise/fmod to get some different results.

Yes, and it’s a very efficient codec algorithm to playback compressed audio in realtime. It allows the playback of dozens (if hundred) of samples concurrently, which is the point. You can’t really expect pristine quality when a solution is optimised for high scalability and low performance consuptions in mind.

That being said, i think with enough experiments you can get to the point where the audio sounds good enough for you. You should also look into the engine’s built in media framework which supports high range of sources for audio and video both.

The 22k / 44k limitation is absolutely false, the engie can in fact play many sample rates, and to my experiences 48k suits the best to the new audio modules.

Btw, you sure you have setup the engine to use the new (experimental) audio mixer feature? That could potentially ‘sound’ better.

Thank you for reply, Konflict

I found somthing that is not an audio codec/compression problem. When I convert wav to mp3 or OGG using RX6, I rarely hear differences. As you said, OGG is better than MP3

Please Check this link
https://www.dropbox.com/s/x2ubfnynho…p3ogg.wav?dl=0
(Test Condition = 16bit 48k)

FIrst one is WAV and MP3, OGG, Unreal Output (PlatformHeadroomDB=0 in WindowEngine.ini)
Also I attached RX analisys.

WAV
wav.JPG

MP3
mp3.JPG

OGG
OGG.JPG

Unreal Output(not using Xaudio2)
unrealoutput.JPG
There’s difference between OGG and Unreal Output. I think it’s more fundamental problem before mention the codec/compression or sample rate

I think something’s wrong somewhere.

I found more. As Konflict said, I guess the problem comes from Xaudio2

I set up the new audio mixer feature but Myproject dosen’t use Xaudio2.

I made new project then Xaudio2 was working. Sound was fine.

Yes! This is the issue. I created a new project (4.19.2), and enabled AudioMixerXAudio2 on that one. The sound was then fine. However, following the same steps on my initial project(4.18.3), it did not switch the AudioMixerXAudio2. It remains on Xaudio2.

I’m not sure why UE does not switch to AudioMixerXAudio2. Maybe one of the devs can help with that. I’m going to continue looking into it.

In my case, Steam Audio cause problem. Xaudio2 and Steam audio cannot be activate at the same time. If I want to use steam audio, I had to hear sound lossing…

Any news/solutions? I have been working on a project for the past 2 years, and even with the new mix engine activated (it was made before the new engine), I notice a lot of loss in the high end.

We identified a bug in the per-source filters causing spectral energy loss, the fix should be in 4.23 now.

Awesomeness!!!

Can you get ID on https://issues.unrealengine.com ?

p.s.: we have same problem with sound quality

Are you fixed this bug in 4.23? Can’t see it in Upgrade Notes.