Unreal Remote 2 connects but doesn't detect iPad Air 2 movements

I bought a new iPad Air 2, assuming that it would work with Unreal Remote 2 for the Virtual Camera System. I asked the community if Unreal Remote 2 worked on iPad Mini, Air and other iOS devices, and not just the iPad Pro, which I was told, it does.

I followed all the steps here: https://docs.unrealengine.com/en-US/…gin/index.html

:ballot_box_with_check: Opened port 2049
:ballot_box_with_check: Enabled the Virtual Camera plugin, Apple ARkit and Remote Session
:ballot_box_with_check: Set the game mode to VirtualCameraGameMode
:ballot_box_with_check: Added to DefaultEngine.ini and restarted the editor:

:ballot_box_with_check: Enabled Always Show Touch Interface in Edit > Project Settings > Input
:ballot_box_with_check: Set Game Viewport Settings to Ipad Air 2
:ballot_box_with_check: Set the play settings to New Editor Window (PIE).
:ballot_box_with_check: Added the IP address to Unreal Remote 2

It connects and shows the camera view and UI icons. I can move left, right, up and down with the control pads on screen, all the UI’s work.

But the iPad gyroscopic movements are not detected… I have tried this on two separate computers and got the same issue.

My concern is this:
“You will also need to have an iOS device that meets the ARKit prerequisites in order to track the device’s movement and enable the Apple ARKit Plugin inside of UE4.”

If anyone has a solution, I’d appreciate the help in getting this issue solved.


I have the same problem. Have iphone 6 plus but no gyroscope input. Also my phone is not supporting ARkit so I confirm that you need to have supported ARkit device.

I upgraded to an iPad Pro, and it works fine on that device. So I confirm that the iPad Air 2 is incompatible.