Unreal (might) be not saving assets properly?

So I have had this Unreal data loss problem for about 3 times now.

First and second time it was when editing and saving a blueprint,
say I have a Blueprint called BP_A, based on a C++ class called CPP_A,
when I finished editing BP_A,
I saved everything, and confirmed it worked in game,
then I closed Unreal editor then reopen,
but for some reason,
BP_A was not working,
and no breakpoint gets hit in Blueprint editor.
so I dive into C++ to see if things work there, turns out everything in CPP_A gets triggered normally,
then I reopen BP_A and clicked on Compile, now things works fine…
but after it if I close Unreal and reopen it, things stops working unless I click on Compile button, as a loop.
(of course assets are being compiled and saved, confirmed multiple times.)

Third time it was a data asset,
say I have a DA_B,
and I do settings in it, saved everything, also confirmed data being used in game normally,
but after I close the editor and reopen it,
inside of this DA_B it is empty…

first and second time solved by itself for automatically after I frustrated for some time,
now I am facing the third time again,
and I really don’t have a clue.
so asking if anyone had similar things happened.

I think this looks really like Unreal is not actually saving my file,
or discards my saving after I close the editor.