Download

Unreal is not importing UV MAPS!

Please help! Unreal is not importing any maps. Like, there is no UV data. When I open up a mesh, I click on UV to show the uv and it is empty. When I select channel one, it is also empty. Everything looks black. I don’t know what to do. Any and all help is much appreciated.

The first thing to check is are you exporting the UV maps? Sounds silly but it’s entirely possible that you’re not.

What software are you using to make the FBX?

Thanks for the reply!

I am almost certain I am exporting the UV data. I am using Rhino and spitting out FBX’s. I tested OBJ’s just to make sure, but nothing works. For some reason, Unreal is not picking it up

Any other info I can give that might be useful, lemme know! Im fighting this

Do you have Blender ? Do you know basics of it?

If so, you could load your OBJ into Blender and see if UV map is there. If it is, export to FBX from Blender, bring it into UE4 and see if lighting bakes well. If it does - Rhino has FBX export issues.

Hi! I tried it with 3ds Max :frowning:

It was in there and when I exported it from 3ds it still did not work.

Could it have anything to do with MikkTSpace?

I tried it from a brand new file, still nothing… :frowning:

They said over polycount that this was also an issue when importing megascans assets 4.13. The UVs just won’t import. Should be fixed in 4.13.1.

Oh man, so I have to wait for the new one to come out? It’s weird, because it was working fine earlier. For some reason, it just decided to stop. Oh well, I guess I’ll wait. Thanks for all the answers! If anyone comes up with a workaround of fix, please let me know.