Unreal, Houdini Engine and shaders


3 pieces of geo generated by the discGenerator hda. The white one is the actual hda in the unreal level and the grey checkered one is the baked geo from the disc generator hda, the one with flames is an fbx export of the discGenerator from Houdini. The hda is using the default shader, while the internal baked geo and the external geo both have the same shader applied. Obviously the grey one is wrong. And, if I applied that shader to the hda, it would be grey checker too. But why does it work on the .fbx Houdini export?

So I rebuilt the shader and it worked on both the hda and the internal baked geo, until… I added the mult node circled here:


After I added that node I coudn’t get it to work on the .hda or baked geo even if I deleted the node. But when I exported basically the same geo as fbx from Houdini, then the shader worked again.

I contacted SESI and they said they don’t think it’s a houdini issue, I probably need some check box checked and I should contact unreal.


In the unreal world outliner; the hda is called discGen and the baked geo is called discGen_2_3_0_0_0 and the imported fbx that was created using the discGen hda in Houdini is called coneDisc_01

I tried rearranging the nodes so that I plugged in a texture object into flipbook and connected result out to the mult node. And that worked.

Still I had to rebuild the shader from scratch because once the shader is built this way, with flipbook out uv → texture sample->multiply: That shader will not work on internal houdini engine hda geo again.