Unreal freezes on creating blueprint from an Actor

Hello guys, I’m new to Unreal and faced an issue.
In a blank project, I created a sphere and hit the blueprint button. But the unreal will freezes 99% of the time and had to Force close it in task manager.
I’ve tested with unreal 5.2.1, 5.2, and 5.1.1 and have the same issue with all of them.

my spec is:
Windows 11 (Up to date)
RTX 4090
i7 13700
Ram 64GB

Can you help me to handle this issue?


Hey there @Behnam.Jef! Welcome to the community! In any of the cases did the engine fully crash or just lock up and stay locked up? If it crashed we may be able to use the logs to determine where the issue is.

However if not, let’s ask some clearing questions.

Do you use any software like MSI afterburner or is your CPU overclocked?

Does the viewport window freeze when opening other asset types that use it like materials or static meshes?

Does it also freeze when opening blueprints that are already generated?

Thanks for helping.

It just luck up. it happens sometimes when changing focus to another application too.

No, I don’t have MSI afterburner and my CPU is not overclocked.

It doesn’t crash on created blueprints, material, or meshes.

This is the blueprint button I have an issue with:
Screenshot 2023-07-11 201825

And this is my project log:

Hrm, so the log itself doesn’t report any fatal errors so the freezing isn’t letting it make it to the crash reporter. This will be a bit of a problem to identify it. Since it doesn’t freeze on already created blueprints, something must be failing during the file creation for actor → blueprint conversion.

Does it freeze on creating new BPs without an actor base or just the BP conversion button?

Does it make it to picking the base class for it? If so what do you choose and which class?

Hey, I do have the same problem, and I’m using Unreal Engine 5.2.1 and up-to-date Windows 11. It just happens on actor base BP, and when I press select button, the program stops responding and it stays like that.

1 Like

Hey there @bke43tr! Welcome to the community! Are you able to create blueprints that are subclasses of actor without this button specifically or not at all?

No, it doesn’t freeze on normal BPs. Captured a video from the issue:

It also freezes when using the blueprint button on the header:
Screenshot 2023-07-13 085803

Having the same issue, editor is totally frozen (not even going to not responding). Is there a workaround?

Great video, definitely fully illustrates the issue! Tough to discern where the issue is stemming from. So far both reports have been on Windows 11 and I can’t replicate this on Windows 10 though it’s possibly coincidental.

Since this isn’t going to be easy to pin down we’re going to need to kind of scattershot to find the fix, but there’s so many reports now this also has to be fully bug reported once we’re done (assuming we can’t find anything workaround/cause wise).

Does this issue occur in other versions for you as well?

Is your project on the same drive as the UE5 install?

Could you try verifying/reinstalling UE5? (formality)

The original user mentioned 99% of the time, are there any errors on the 1% of time it actually works? (not even sure if you can succeed but it’s good info).

Hey there @somnium.1! Welcome to the community! This is a new development, so we’re getting to the bottom of it now. If possible, could you check back through the other comments and answer the same questions as the others to get a consensus?

ie may we know your specs, OS version, affected UE versions etc.

Thanks for your support.

Yes, faced this issue in 5.2.1, 5.2, and 5.1.1. I will try UE4 and report back.

Yes, they are in the same drive. I’ve tested it on different drives as well but the problem exists.

No there isn’t any error when it doesn’t freeze!

Please let me know if there is anything else I can do to find the bug!

Thanks for responding. I’ve tried with 5.2.1 and 5.1.1, both have the same issue.
Laptop specs-
AMD Ryzen 5 4600H
Win 11 Home Build 22621.1848
NVIDIA GeForce GTX 1660 Ti 6GB

Tried with the project in the same directory as the UE5 installation as well as different, issue persists.

Thanks for the information! Your setup is similar to mine in every way but OS, so aside from the other million variables, the picture is getting a bit clearer. Compiling a report on this specifically, I may have more questions when I can discern everything that’s accessed when creating an actor subclass. Going to take a deeper dive into the source to just see exactly all resources this touches and I might have more effective probing questions.

I had thought it could have been IDE/Redistributable related but if compiling any other BP doesn’t fail that’s not it.

The issue is for UE5, installed version 4.27.2 and everything seems fine.

I have an update guys. Just today I got an external monitor, so I started UE5 on the external display only and voila the blueprint editor popped up immediately! I don’t know if this is specific to me but worth a try if your using a laptop. Hope this helps to identify the bug.

Ohhh interesting development! It doesn’t freeze at all anymore?

on laptop’s internal display - yes it freezes, on external display - it doesn’t.


Has the root cause been identified?

Unfortunately not, still trying to find a clearer picture. Every instance that freezes doesn’t lead to a crash log so it’s harder to pinpoint what’s failing. One user is even experiencing all the same issues but only intermittently, but also no crash.

By any chance do any of you own rdBPtools on the marketplace? - you could test by using that to try and create the blueprint.