Unreal freezes/crashes a lot during material editor

Unreal Engine has been freezing / crashing a lot for me when I use the material editor. It is starting to get unbearable. it is hit or miss. Sometimes I can use it and it works fine, sometimes I have to close the program with the task manager. I’ve noticed that when the engine freezes, a message box pops up, but I can’t view it. I’ll notice on my windows taskbar there will be an additional unreal box, but I can’t open it. It is frozen. I have a decent computer, Dual video cards, 16gb ram. There must be something causing this. Is there anyway to fix this?

Hey DanVilas,

Could you provide me with your ‘dxdiag’?

I would try going to Window > Layout > Reset Layout because it sounds like you could have some windows or viewports taking up your processes.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

Here it is:

Intel Core i7-5700HQ CPU @ 2.70 ghz (8 CPUs) Memory: 16gb Video Card: NVIDIA GeForce GTX 980M (2 cards SLI)

Have you attempted the suggested solution?

Yes. It freezes when I click Reset Layout. Task manager says that engine is not responding. However, there is a second window that doesn’t pop up called Reset UI Layout. I can see it on the task manager, or if I hover my mouse over the Unreal Icon on the windows task bar on the bottom of the screen, but I can’t open that window because unreal is frozen. I’m encountering some problem where the engine freezes when a window pops up, such as warning messages. I don’t think memory is an issue since with unreal running and other programs, the total use of memory is at 28% shown in the task manager. I don’t understand why the engine freezes. Another example of the engine freezing when a window pop up happens is in the material editor when I click the tea pot in the preview section where you can preview the texture on a sphere, plane, cube, cylinder, etc… A warning pop up is suppose to come up titled “Warning: Preview Mesh Not Found”. The engine freezes, but I see there is suppose to be a pop up through the task manager or hovering my mouse over the Unreal icon on the windows task bar. Would it help if I record myself encountering the problem and uploading the video?

Honestly, I would try a fresh install of the engine. It sounds like you have some dialog windows getting suppressed, and not being brought to the front of your screen.

A video of the issue you are experiencing would be helpful though. If you can provide me with that example, I might be able to provide some further assistance.

Cheers,

Andrew Hurley

Ok, I will try doing a fresh install and I’ll also record a video of the problem, along with that, I’ll also download a previous engine version (4.10) to test it as well. How should I go about doing a fresh install? Should I uninstall everything and just start over? Will that make me have to redownload unreal and the game engine? Will I lose my project files and assets I bought in the unreal store?

Here is a video of my problem. I show two examples when it freezes when a dialogue box is suppose to pop up:

Quick question, how much free space is left on your (C:) Drive?

When you do a fresh install, you will want to uninstall the Engine within the Launcher, which will not delete your Unreal Project files. If you are worried, you can always create a copy of your projects.

Thank you,

Andrew Hurley

I had almost 30gb of space on my C: Drive before i started download verison 4.10

I just finished downloading 4.10 and I have the same problem where it freezes when a dialogue box is suppose to pop up.

I’ve looked through the dxdiag.txt and I noticed on the bottom there seems to be several problems with Unreal. I don’t really know how to read it.link text

From looking at your diagnostics, it seems the launcher is causing some issues. I hate to suggest it because it isn’t the shortest fix, but you might need to completely reinstall the Launcher and any engine versions as well. Your launcher could be experiencing a memory leak or some sort of corruption which is causing your editor to stop responding.

I would also check to see if you are running the most up to date video drivers for your GPU as well. Hopefully the combination of these solutions resolves your issue, but if not please let me know and we can investigate this further.

Thank you,

Andrew Hurley

I updated my NVIDIA video drivers for GeForce GTX 980M a few days ago to the newest driver version 365.19 …It still gave me the same problem with Unreal freezing before and after the update.

I will uninstall the Launcher and reinstall everything. I’ll let you know.

I uninstalled the engine and the launcher, reinstalled them back and engine version 4.11, and it is still the same problem where it freezes.

Try ending a lot of the other programs running in the background to see if they could be causing a conflict. I noticed you have an Xbox One application that was taking 17% as well as some other applications.

Perhaps you are behind a firewall as well? Be sure you have allowed the Editor and the Launcher full permissions in your firewall settings, if that exists at all.

Do me a favor and also open up the Windows Event Viewer to see if there are any Windows Events causing your computer to drop in performance. Use the Windows Event Viewer Wiki to help explain some of the process when searching.

I looked at my task manager and the Xbox One application wasn’t running and I tried it and it still froze. I looked at the Windows Event Viewer and I’m not sure. It logged a few events when the Epic Launcher was crashing on me when I tried opening it yesterday, but i fixed that by going to the Nvidia Control Panel and under Manage 3D settings > Power management mode and changing it to Prefer maximum performance. This error is listed as:

Faulting application name: EpicGamesLauncher.exe, version: 2.11.10.0, time stamp: 0x57345571
Faulting module name: KERNELBASE.dll, version: 6.3.9600.18264, time stamp: 0x56e1bd71
Exception code: 0x00000001

One part of an error in the Event Viewer i’m confused about, around the same time as I was having that problem was this:

Faulting application name: UnrealCEFSubProcess.exe, version: 0.0.0.0, time stamp: 0x57345686
Faulting module name: libcef.dll, version: 3.2357.1291.0, time stamp: 0x56c38a4e
Exception code: 0xc0000005

SubProcess caught my eye, but I don’t know what to make of it.

Well that is actually helpful, because I found a user who had a similar report.

He resolved it by uninstalling Nahimic Audio Software which is directly related to MSI users. Try this and let me know your results. We will get to the bottom of this!

And that fixed it! You have been very helpful. Thank you for everything!