Download

Unreal Engine + Oculus SDK1.3 available in GitHub

Just so you know. You can download Unreal Engine for 4.10 or 4.11 preview 6 with support for SDK 1.3.0 to gedt your apps / games working on the Rift at last.

www.github.com/oculus-vr/unrealengine

Any news here from Epic about availability of support directly from the launcher. Perhaps in next versions of 4.10 and in a new preview of 4.11?

Thanks for the info Jumbli!

I imagine odds are good of it being in 4.11. (News from stream: No more previews - Release is imminent!)

Anyone know the magic words to summon a Nick Whiting? :wink:

Thank you! I was searching far and wide and happy I found this.

Wondering if it’s worth waiting for 4.11 or compiling the 4.10 1.3

Ooh word on this would be very good pls.

I do hope 1.3 is in 4.11. We waited so long for it, we just can wait a little bit longer :slight_smile:

Any get this working?

Built from source on latest Git and am getting compiler errors:

Error LNK2019 unresolved external symbol NvAPI_D3D_ImplicitSLIControl referenced in function “protected: void __cdecl OculusRift::FOculusRiftPlugin::DisableSLI(void)” (?DisableSLI@FOculusRiftPlugin@OculusRift@@IEAAXXZ) UE4 E:\UnrealEngine-4.10\Engine\Intermediate\ProjectFiles\OculusRiftRenderD3D.cpp.obj

Error Failed to produce item: E:\UnrealEngine-4.10\Engine\Plugins\Runtime\OculusRift\Binaries\Win64\UE4Editor-OculusRift.dll UE4 E:\UnrealEngine-4.10\Engine\Intermediate\ProjectFiles\ERROR

Error MSB3073 The command “…\Build\BatchFiles\Build.bat UE4Editor Win64 Development -waitmutex” exited with code -1. UE4 C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets

I’ve tested the Oculus Runtime 1.3.0 with 4.10.4 and 4.11.0 Preview 8. On both the glasses are not working. Hopefully there will be an update, soon…

Make sure the latest GPU drivers and Oculus 1.3 are installed before compiling.

I’m waiting for my rift so for the time being I use 1.3 with the DK2. Is there a way for the DK2 to be recognized (the VR preview is shaded and headset is not recognized when launching UE4 game packaged with this version)?

Is there someone with a CV1 able to tell me everything is allright? Does the rift is automatically recognized (and yes I checked the unknown sources option)?

Thanks!

Proteus, I assume you have installed Oculus Home and recompiled GitHub code with 1.3 support. When I load UE 4.10 it auto loads Oculus Home and the VR Preview button is enabled. Packaged builds work too. I am testing with a DK2.

Yes I did that. Games on Oculus Home works. I had no trouble recompiling. I just launch the recompiled 4.10, start a blueprint FP scene, Oculus Home starts but no VR Preview. But I had troubles with the HDMI cable you give me hope. I’ll try it again thanks!

Hi, i do not have access to the github. Hoe do i get unreal 4.10 working with my dk2 and runtime 1.3.0? The vr preview button is greyed. Thx for helping me.

I’m seeing the same error here. I’m using the latest geforce drivers and SDK1.3.0. Oculus Home is also installed.
help…:frowning:

Hey guys, I’m looking into this problem as well, but had another one before I got to this one.

Before my first compile (this was found on my second), I ran Setup.bat and it found 2 files that were already present in the Oculus build, these files were:

“Engine\Source\ThirdParty\NVIDIA
vapi\x86
vapi.lib”
“Engine\Source\ThirdParty\NVIDIA
vapi\amd64
vapi64.lib”

So if you select to keep these files, so NOT replace/override them, then I could get it to build and run just fine, with 1.3 and Oculus home working. But my Android build failed with some physx errors and I need that working, so it’s still a problem for me.

Try to replace your current files (specified above) with the ones from Oculus, they are not the same, hopefully you can get it to build then, I can.

It works now. I started all over and kept the existing Nvidia api files as you said!
Thank you so much N8128 !

A warning: After I integrated the Oculus SDK 1.3 UE4.10.4 integration, SteamVR stopped working unless I disabled the Oculus Rift UE4 plugin. :frowning:

Stormwind, you can also just stop the Oculus service before you start UE4 when testing SteamVR. I’ve set the service to start manually rather than automatically so I can easily switch between Steam and Oculus.

Jumbli, thanks for the tip. I had trouble starting UE4 at all. The Oculus launcher would pop up, and interfere with it – there would be no icon on the task bar, and the loading screen would only appear some of the time. If it did appear, it would stop at 83%, and not move, even when the shader compiler processes had completed. Stopping the Oculus VR Runtime Service allowed it to finish loading and get to the Project Browser.

Yes, nvapi and nvapi64 libs are updated to newer versions in Oculus github, and Setup.bat is overwriting them back to old version. The workaround is to get those files from repo again, after Setup.bat is used. We will update the Setup.bat to preserve those files.
As to SteamVR, this is a known issue, Epic guys are working on it, I believe (for 4.11.1; once this is done we’ll be able to update 4.10 integration in our github as well). SteamVR plugin should be updated to comply with some recent changes, i.e. IsHMDConnected function should be implemented correctly for it.