Download

Unreal Engine is exiting due to D3D device being lost AGAIN AND AGAIN

Hi

I have noticed a new issue with UE 4.24 when shaders are compiling if I tried to move around in the level even a little movement, or play the level the editor will crash with message

Unreal Engine is exiting due to D3D device being lost. 

also when renaming/moving a folder that has many items (lets say a folder contains +600 animation sequence)

Exactly the same problem here. My editor crashes when shaders are compiling if I tried to move around in the level even a little movement, or play the level. And same error message…

My config : MSI Gaming GP72MVR 7RFX-863CZ Leopard Pro - GP72MVR 7RFX-863CZ laptop specifications

Got the same problem. Been trying seemingly everything to try to fix it. But got nothing that works. I’ve updated to latest Win 10 drivers, Nvidia Studio Drivers, Motherboard bios and Graphic card bios. Underclock CPU and GPU, changed registry settings. Reinstall programs etc. The D3D device being lost is driving me insane. It only is UE4 that I have problems with on my computer. No other programs.

I use:
9900K
RTX 2080 Ti
64 GB ram
Win 10

Check you laptop charging cables and ports guys. I had a similar issue when I had my P.O.S. Razer Blade (Never buying Razer again, but that’s a story for another day.)

Most laptops with discrete graphics will auto-switch to the built-in Intel gpu when it switches to battery. Unreal doesn’t know what to do, and so therefore it crashes.

If not that check you’re GPU TDR Delay. If you’re doing stuff with a lot of info or computation, the default TDR delay might cause the driver to stop responding and therefore crash.

You can find quick info on the first post of this thread just prior to the change log: https://forums.unrealengine.com/deve…ss?view=thread

Hopefully this helps

I’m experiencing this same problem too. MSI Laptop GTX 1070, i7 with plenty of RAM. The crash only started to occur when I updated to version 4.24
I suspect it has something to do with how Epic is modifying DirectX support to introduce ray tracing. I did try the GPU TDR Delay fix that Riley1389suggested. Unfortunately it doesn’t solve the crash, but instead it just results in a longer hang time before Unreal quits.

Same here, an insane amount of crashes due to d3d device being lost.

Nothing seams to work.
9700k
rtx 2070 super
64 ram
win10

So, I’ve run the d3ddebuger and got this results. Hoping this will help.

Actually saying it’s from the GPU switching is useless, I was using UE4 as I remember since 4.15 (maybe before i don’t remember) but never saw this amount of repeatedly crashes due to d3d lost beside i already searched the internet and tried many solutions including TDR and Nvidia driver (game and studio ready) nothing helps

So, I’ve fix my problem using the Display Driver Unstaller and cleaning my registry before reinstal my nvidia drivers. Now Unreal is stable again.

hi i have this problema anyone??

[2020.03.30-21.47.24:187] 0]LogThreadingWindows: Error: Runnable thread RHIThread crashed.
[2020.03.30-21.47.24:187] 0]LogWindows: Error: === Critical error: ===
[2020.03.30-21.47.24:187] 0]LogWindows: Error:
[2020.03.30-21.47.24:187] 0]LogWindows: Error: Fatal error: [File:Unknown] [Line: 198]
[2020.03.30-21.47.24:187] 0]LogWindows: Error: Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0020 - ‘INTERNAL_ERROR’)
[2020.03.30-21.47.24:187] 0]LogWindows: Error:
[2020.03.30-21.47.24:188] 0]LogWindows: Error:
[2020.03.30-21.47.24:188] 0]LogWindows: Error: Unhandled Exception: 0x00008000
[2020.03.30-21.47.24:188] 0]LogWindows: Error:
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ffa964da859 KERNELBASE.dll!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff783270986 FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff7832714cf FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff78322292d FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff7836ff087 FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff7836ff896 FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff7836f44f3 FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff783fb0a0b FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff783fb10f4 FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff78312f983 FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff78400fbfb FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff783279167 FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ff7832763ac FortniteClient-Win64-Shipping.exe!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ffa97597bd4 KERNEL32.DLL!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error: [Callstack] 0x00007ffa990cced1 ntdll.dll!UnknownFunction ]
[2020.03.30-21.47.24:188] 0]LogWindows: Error:
[2020.03.30-21.47.24:188] 0]LogWindows: Error: Crash in runnable thread RHIThread

I was having a really hard time with this error after upgrading from 4.23 to 4.24. I had never seen it before, but after the upgrade this error would crash the engine on my about every 10-15 minutes. More frustrating was the lack of information I found regarding it.

I did 3 things that I believe finally fixed the error.

  • I reverted my NVIDIA Game Ready Drivers back to the 2/27/20 driver. Every driver I tried post-March '20 was crashing.
  • I uninstalled Geforce Experience.
  • I disabled my Intel integrated graphics card, so only my GPU is running.

Hope this helps.

1 Like

BLUF - don’t maximize your UE4 UI window, hit that little multiple window or “restore down” button and then just grab the corner and scale the window up to fill your screen.

Tried all the stuff on these posts and found that this fixes it for me.

When the Unreal UI is maximized in 4.24 and 4.25, the UI itself stutters on my desktop and completely crashes with the D3D device error on my laptop. I think it has something to do with fullscreen mode interacting with the integrated intel card on my laptop even though I have a 1060 in it. I’m going to make a video showing this issue and how consistently I can recreate and fix this problem and them submit it to epic to see if they can fix the underlying problem since it only happens on the latest two engine versions.

Really hope this helps,

Phil

Edit: to further my suspicion, running OBS (to try and capture the bug) fixes the issue too and OBS only works if it is set to use the integrated card. Immediately upon closing OBS and trying to interact with maximized UE4 UI starts crashing stuff again.

Minimizing didn’t help, it still crashes a lot.

I’ve manged to resolve the issue by updating NVidia Drivers to the latest one (Version: 445.87) and preforming a “Clean install”.

Also, I changed the “Preferred graphics processor” option to my “NVidia Graphics Card processor” instead of 'Auto-Select" in the - NVidia Control Panel - due to the fact that I found out, that sometimes UE4 switches to the Integrated Graphics Card and causes the crash to happen.

Hope this helps! :smiley:

impostekno

None of the above solutions worked for me (reinstalling UE4/project/updating drivers/setting NVidia gfx to default).

What did work: When I plugged in a second monitor, the error went away.

It feels like it had saved some info from a prior session where there was perhaps a window on a second display? By my experience, the issue seems very likely to be something saved in the UE4 engine or project .ini files and/or registry settings as I wiped out just about everything else in my attempts to clean things out.

Solved - for me

Tried all the recommended solutions but none of those worked for me. What worked for me was going in device manager and updating my intel display adapter driver (i first uninstalled it through device manager)

I have an Acer Nitro 5 laptop with a Nvidia GTX1050ti.

When using the editor I also checked Task Manager and I can see that unreal engine is using my Nvidia display card now.

Originally my editor would crash when in full screen mode so I had been working in windowed mode but every now and then I would accidentally snap the window to full screen and get a crash, with D3D device lost… So glad this is sorted now!

Hi, I am trying to launch the Engine the very first time (it wont) and get this error message:
Fatal error: [File D:/Build/++UE4+Licensee/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Util.cpp] [Line: 198] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0007 - ‘RESET’)
I dont have a drive D: in my PC. Any hints what I could do, please?

This issue has been driving me nuts. It happens very consistently, it will crash after I do about 20 actions.
Tried updating GPU (nvidia) drivers, starting a new project, turning off 2nd monitor. No luck.

ue 4.24.3. Windows 10 desktop system.


LoginId:fe21394144c437cf55bd32b4d9782c20
EpicAccountId:9564f6f6614142f887f341119fece27a

Fatal error: [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Windows/D3D11RHI/Private/D3D11Util.cpp] [Line: 198] Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0020 - 'INTERNAL_ERROR')

UE4Editor_D3D11RHI
UE4Editor_D3D11RHI
UE4Editor_D3D11RHI
UE4Editor_D3D11RHI
UE4Editor_RHI
UE4Editor_RHI
UE4Editor_RHI
UE4Editor_RHI
UE4Editor_RHI
UE4Editor_SlateRHIRenderer
UE4Editor_SlateRHIRenderer
UE4Editor_SlateRHIRenderer
UE4Editor_Core
UE4Editor_Core
UE4Editor_RenderCore
UE4Editor_RenderCore
UE4Editor_Core
UE4Editor_Core
kernel32
ntdll

I get exactly the same message when using Radeon. My notebook has an AMD Radeon GPU and an Intel HD. With the Intel I get the DirectX is required, although DX 10 is running. Appears to be a very unstable SW.

Does anyone have a solution? I recently built my PC and it works fine on my laptop but doesn’t on my PC which is ironic because this thing is a beast.

AMD Radeon RX 5700 XT
AMD Ryzen 9 3900X 12 core 24 thread
AMD Motherboard MPG X570 Gaming Plus

I’m using the 4.25 version of Unreal and every time I start editing my project it stops and ends up crashing. Then it starts messing with monitor . Any help would be amazing.