Unreal Engine 5 Freezes when saving packages or saving anything

Same issue here with different materials.
I noticed it happens when I use many instances of the same master material.
Updating the master material as mentioned above (changing anything, apply, revert, apply) fixes the issue.

Guys when you changing something in materials - it does not solve the problem. The issue is in Material System probably and it can be fixed temporary by forcing recompile of the material.

When you changing something in material - you forcing it to recomplie. THIS IS WHY YOU START TO THINK THAT YOU FIXED SOMETHING.

But you have not. You just reshuffled it so now other materials will stop saving.

It doesnt matter what are your specs, or how your materials are made. I even got this on freshly created instance that I have just created. And on our project there’s a lot of people with different hardware. So there’s 100% something broken in Unreal material system in 5.3 which causing these freezes. They are also different for different people even if they have the same content on the same project. For some lets say material A causing freezes for other’s it will be material B and for each person it will be his own material. The only consistency here is that until you recompile it will be always the same material that causing this.

As I said you can temporary fix this by forcing recomplile.

There are multiple ways:

  • Though editor utility blueprint (there was a force recomile command if i remember correctly so you can make your self an asset utility to fix this).
  • You can turn on or off any switch in material instance - which will force this material to recompile.
  • You can open master material and change something there and hit apply - this will also force recompile.

But again - this is a temporary fix. After some time this issue will start to happen with other materials. Especially if you have a lot of them.

3 Likes

I had the same problem. Disconnect a node in the material + apply then reconnect + reapply. Solved the issue for me.

Its not. Your “solution” is temporary. Look at my post above.

And also I have a question do you have a chain of inheritance in parent materials for the instances that are not saving or its just a master material there?

I have a suspicion that this happen when you have a chain of inheritance.

UPD: Nope. Just tested and its not because of the inheritance chain.

My windows 10 32 gb DDR3 intel i5 3.3ghz machine with a GTX 1650 4GB ddr6 video card was doing this very thing when applying a new PNG graphic to the hoodie on my metahuman. must have searched for hours and forced CTRL+ALT+DEL task manager end task on engine 9 times…tried everything

BUT, when i went into Project Settings and switched from DX12 to DX 11 and restart, everything worked and was much faster ( after 2 hours of rebuilding shaders)…hope this helps. no more 0% Saving or eDITOPR fREEZE

1 Like

Any new insights? This has been plaguing me for a few months now,
without finding any solutions, nor a lot of reputable people facing the same problem.

Are you using virtual texture samplers as well?

1 Like

what if I have this bug with a 3060?

Yes and no. We are using virtual samplers but not for everything.

Also this happends only on layered materials but they are using VT’s only partially. As well as on props its okay (and props are also using Virtual Textures).

Also I’m not sure if its related - but we’ve noticed that some shaders have started to render as checkerboard until you recompile them after we added RVT blend to props shader.

It really hard to test this, because its seems random and you need actually a big project for that.

And unfortunately this all the information I have.

May be its related to blend material attributes node somehow?

You’re right actually, I just remembered that I had this happen on meshes,
but also the landscape (adjacent) material parts, where I’m not using virtual textures.

I’ve been working for a bit on UE5.4 now and haven’t had a complete stall yet.
There’s been a few times I was afraid it’d start freezing again, but it has always recovered so far.
Usually I’d have had it happen surely 3-4 times an hour, but ~20hrs later so far nothing.
And like I said, this has been plagueing me for a long time now.

I’m somewhat optimistic that there’s been a fix, but I’ll report if it happens again.

if anyone could help me, i don’t know how to ‘forcing an update/compilation of the different master materials’ to solving the problem

The simpliest way is to open any master material, make some change and revert the change back. And then just hit apply it will recompile.

You can just unpin some node and pin it back for example.

Yeah I have the same hope that it was fixed in 5.4…

I suddenly got same error. I am not completely sure but in my case I think it was related with the maps.
I moved and I think there was a kind of duplicity with names.
I created a new map, deleted the old one and now I dont have the problem anymore.
I hope this works for you

I found something that fixed it for me.
So apparently the Materials that caused the freezes when saving, all had:

  1. One or multiple Textures that had their Compression set to “UserInterface2D (RGBA)”
  2. “Two Sided” set to true in either the Master Material or a Material Instance

[fix]
I set the compression in the Texture to Default, and after that everything worked out fine for me.

My guess is that the UI Compression thingy clashes with 2 sided Materials, which makes sense to be fair, which then causes it to not be able to save/apply?

Hope this helps.

1 Like

Guys please read the whole thread before posting your solutions.

The issue looks like “fixed” when you recompile the shaders. Meaning that it doesnt matter what you have changed in the shader. At the moment when you hit apply - it “fixes” the issue temporary. Because when you hit apply - the editor recompiles the shaders.

And that’s it. Its not related to any settings, because we all have different setups and the same problem.

Recompiling is a temporary fix, after a while it will start repeating.

2 Likes

Yes, sir. 2-sided indeed. I am using USD model it has a lot of 2-sided when imported. Going to stay away from 2-sided for a while.

Going straight to the Master Material and unhooking the Diffuse pin, Saving, hooking it back in, Saving again, worked for me. You have to close the Editor and re-open it for it to take effect though.

same problem here. just recompiling the master material without an editor close has solved the issue for now.

Resaving my master material fixed this error for me.

I ran into the same problem (I am still on UE 5.3). On a very fresh tiny project.

It happened on a skin material instance first - I do not know if from a pure coincidence or there’s something else to it, but even after creating a completely new project (just a template scene with imported few materials and single FBX character), the issue repeated itself on the very same material instance.

It either cached something outside the project or I was just unlucky (recompiling master material helped).