Download

Unreal Engine 5 First time Custom Car/Vehicle issues. (Simple Wheeled Vehicle Component & Wheeled Vehicle BP)

Hello, I am having days worth of issues trying to get my custom created vehicle from blender working in ue5 for a car mobile game I’m trying to develop. I have followed many tutorials and could get none to work, I am having trouble getting my custom vehicle to move, the wheels aren’t moving either so that’s another issue. I’ve setup my blueprint in many different ways, all based on different methods of implementing ue4/5’s simple wheeled vehicle component and I have even tried the wheeled vehicle class as well, none have worked and I have performed a lot of research on collisions, unit scale and proper axis. Everything seems to be setup perfectly in my project right now, and it is currently modeled after this tutorial ( (https://www.youtube.com/watchv=ZKP0heuQdVY&t=435s) )as its the one Ive done last

Hello Mcvay,
I had never tried to get to know how to program a vehicle in Unreal Engine… until almost before the release of Unreal Engine 5. I knew that I will program a car game in the future, so I started trying to find it out. When I wanted to get to know how to do it, I was in holidays and my computer is at home so I wasn’t able to do it. When I came home UE5 Early Access was released and I downloaded it - and also where I tested how to make a car working. But I wondered why my wheels are not working - also like in your case - and I couldn’t find it out. I then tried to do it in UE4: it worked. And that’s the problem: Epic Games also said that you shouldn’t use the UE5 Early Access to develop any game, because it’s not perfect, it’s only for kinda testing the new features and reporting the bugs. And that’s a bug. The new Unreal Engine has the Chaos Vehicle System and that’s a different one to the one before. And I think you guessed it right: it’s just a bug, that you should report to Epic Games. I hope that I am right and that I’m not saying anything wrong here, just write to Epic Games. I hope you are having a good day!

ok don’t panic your issue (didn’t read all) is known and people are working on it, hopefully we’ll get a fix sometime soon
check this thread, UE5 Chaos Vehicles

Make sure you have a torque curve. I converted my project from UE4 with the Simple Vehicle class and had to implement the Chaos Vehicle Movement class for my project. Nothing happened until I added a torque curve.

@pookemon 's answer is one of the cause. I encountered same issue but with a torque curve.
In the end, I made a custom bp(alomost same functional as tempalate BP) and everything is runs well. You could give a try.