Download

Unreal Engine 5 crashes while opening UE4 project

As suggested in the migration guide, I started UE5 and opened our UE4.26.2 project, then I selected Open Copy.
Unreal Engine 5 loads up fine. But then while Preparing Static Meshes and while Waiting for Static Meshes to be ready is being displayed the Engine just freezes and eventually crashes.

I’ve attached all the relevant crash report files.
Would someone perhaps be able to tell me what’s going wrong?

From what I see it seems like the crash occurs during QuadricMeshReduction?
We have tons of highpoly meshes in the project in preparation for UE5, so I guess that could be an issue to convert them all.

CrashContext.runtime-xml (146.2 KB) CrashReportClient.ini (112 Bytes) Stormbringer.log (110.3 KB) UEMinidump.dmp (882.9 KB)

1 Like

same problem here

I have since been able to further isolate this crash issue.
It happens to meshes which are past a certain triangle count.

For example, (at least on my PC) a guaranteed way to make UE5 crash during project migration is to have a 4 Million+ triangles mesh in the UE4 project.
Interestingly enough, this happened both on my PC with 32GB RAM and one with 64GB.
I doubt it’s a hardware limitation, the crash seems to happen to everyone, past a certain triangles count of the UE4 mesh.
What’s the best way to report this issue to Epic right now?
I didn’t see any UE5 related issues on AnswerHub yesterday, at a quick glance.

I found a cumbersome workaround:
In your UE4 project, create an empty map and make it the default startup map for the game and the editor.
Now migrate the project to UE5, it will not crash anymore, because the map is empty and has not highpoly meshes in it.

In UE5 right-click on content browser folder that contains your static meshes, or just the Content folder of the project. → Audit Assets.
Sort the list by Exclusive Disk Size.
Start opening up static meshes with the highest disk size.
They’ll all crash the editor, because high disk size == high polycount.
As you go down the list, eventually no crash will occur once the polycount is low enough.

Now, at your own risk, delete the static meshes that caused the crash, when you opened them.
Then, (re-) import them into UE5. Curiously enough, importing the meshes directly into UE5 does not cause the crash. Now you can open your map, which used to have the deleted meshes.
If you had them placed in the map, you can now select the imported meshes to be used in place of the deleted ones again in the map.

PS: If anyone from Epic reads this, this workaround is NOT sustainable for us in the long run, since we’ll continue to develop in UE4 this year, but need to convert the project to UE5 every month, or so, to check performance, compatibility etc.
So using this workaround would easily cost our team 1000s of dollars worth of work-hours during 2021.

Same here too. I’ve tried some solutions and nothing works. Too bad, i would like see my project in UE5.

If you delete all meshes with more than 2 Million triangles from the project while it’s still in UE4, it should work in UE5. (Just make sure to make a backup of the project first.)
At least for me the limit seems to be somewhere around 2 Million.
It might depend on how much RAM you have, or something like that, not sure.

You could also use the creating an empty map in UE4 and setting that as editor startup map trick.
That I mentioned in my previous post to get the project to load in UE5.
Then you can simply see which are the meshes that make UE5 crash by double-clicking them in the content browser of UE5 to open them up. Then delete those in UE4, before you convert the project to UE5 again.

I really hope Epic fix this issue soon though, so we don’t need horrible workarounds like that!