Unreal Engine 5.1 Preview

Was hoping UE-155378 “Wobbling effect on meshes” was related to the transform issue but unfortunately it is not.

Transforms still suffer precision issues in UE5.

In UE4 this looks like:

While in UE5 it looks like:

1 Like

Are there any workarounds to this or are we doomed to flickering precision now?

Hello!

Version 5.1 is crazy especially in VR. But I encountered a bug with the HMIs and Widget Interaction of Motion Controller. I feel like I’m losing the focus of my widgets.

Reproduction of the bug:

Take the example «Virtual Reality», add buttons and even a slider in the «WidgetMenu» and interact with them.

The slider does not behave properly and the buttons remain «hovered» after one or more clicks. They return to normal once I interact with another button.

I use version 5.1 Preview 2, the OpenXR plugin and a Valve Index (so steamVR 1.24.6)

Thank you !
Choub

This will be addressed in the release. SM6 uses a new shader back-end from Microsoft that has more verbose instructions for the same level of shader complexity as SM5. A change went in after Preview 2 that will apply a rough multiplier to make the SM6 numbers look more like SM5. This will generally fix the shader complexity viewmode, but there will still be differences from SM5 instruction counts. SM6 instruction counts should only be compared to other SM6-compiled shaders.

4 Likes

Just replied in this thread, let’s move any further conversation there.

1 Like

I am looking for the persist changes in multiuser server. Anyone found this?

I’ve been seeing this issue with a number of things using Nanite in 5.1. None of the settings on the meshes really do anything that I could see. This is using the “Modular Scifi Season 2 Starter Bundle” off the marketplace but it does apply to a lot of other meshes. It’s a new project just enabling Nanite on the meshes.

I’m using an RX 6800 XT with 22.10.1 drivers on W10. The same thing happens with an RX 480.

r.Nanite.ProgrammableRaster 0 is the only thing that seems to make these issues with missing geometry go away which I guess is closer to 5.0 functionality.

Thanks for the clarification, however I do not understand how a shader code which has 2 or 3 times the amount of instructions of its predecessor could be as efficient. Any light shed on this would be appreciated.

2 Likes

[EDIT: reply accidentally got duplicated, deleting one]

The instructions used to derive the count are abstract, they are not direct GPU hardware instructions (which are different for every GPU vendor). They are referred to as an “intermediate language” (IL). The IL is converted to GPU instructions by the graphics driver at a later stage. The final GPU instructions should be roughly the same whether from SM5 or SM6, but the IL for SM6 is completely different. It is documented here if you are curious.

3 Likes

I started having problems with MetaSounds in this version. Although it works perfectly fine in the editor and debugging the game/simulation. But when cooking and packaging, the generated executable does not start.

Opening with the -log parameter, the last log call is:

[2022.10.30-19.04.21:268][  0]LogMetaSound: Error: Target interface is not registered [InterfaceVersion:UE.Source.OneShot v1.0]
[2022.10.30-19.04.21:271][  0]LogMetaSound: Error: Target interface is not registered [InterfaceVersion:UE.Source v1.1]
[2022.10.30-19.04.21:271][  0]LogMetaSound: Error: Target interface is not registered [InterfaceVersion:UE.OutputFormat.Stereo v1.0]

After these calls in the log, the executable freezes with a black screen.


I saw a similar issue that was already fixed in Unreal 5.0: Unreal Engine Issues and Bug Tracker (UE-150434)

In my case, I was also using FObjectFinder, so after seeing this link, I chose to declare a UPROPERTY and assign the value via Blueprint, but it didn’t solve the problem. In the project where I’m having this problem, I’m using MetaSounds in a Modular Feature/Plugin (via Game Features & Modular Plugins)

Also tried setting the plugin (in this case, changed my plugins - Metasounds is declared as PreDefault) Loading Phase to PostDefault, but did not change the result.

  • Note 1: I’m packaging the project for Win64 and this was not happening in Unreal 5.0 (I understand that it is not recommended for shipping projects built in this preview, my project is not a finished game and will not be distributed. I’m packaging to perform more tests outside the development environment)

  • Note 2: This project was converted from Unreal 5.0 to 5.1 P1 and then to 5.1 P2.

Anyone else having problems with UUserWidget::SetPositionInViewport()?
With 5.0.3 my drag-drop widgets (based on the official tutorial Creating Drag and Drop UI | Unreal Engine Documentation ) worked perfectly fine, now they are all stuck at position {0,0} (top left) and SetPositionInViewport() does not change anything, despite getting the correct position input values.

It seems they added a new subsystem for handling widgets (UGameViewportSubsystem), perhaps it’s not working correctly yet?

Do you have any updates regarding Nanite in Linux and macOS? :slight_smile:

There is no workaround that I am aware of. I also don’t know if this is intended or a bug since I can’t seem to get a response to that from Epic. :frowning:

I haven’t been able to find someone with the same problem here, so I’m asking:
I can’t open version 5.1 preview 2.
The initiator starts up but closed when it reaches the moment of opening, this happens every time. Version 5.1 preview 1 could be opened without any problem and it worked perfectly.

Does this happen to someone? Any suggestion?

PD: Ok, solved,update Quixel Bridge plugin

I don’t know if it’s reported but when I “CopyPaste” elements from a project to another, UE 5.1 PV2 Crash.

Hope this helps.

A 5.0.3 Project with simple DMX faders does not work when upgraded to 5.1. Any insights?

I have a simple project that fades DMX channel 1 up and down. The project functions as expected in 5.03, but not 5.1 preview 2.

Has anyone tested compiling the 5.1 branch in an M1 Max with MacOS 13.0 Ventura and Xcode 14?
I am giving this a try to see if at least I can get the editor and the compiler to work (broken after upgrade to Ventura :-1 )

1 Like

I am also having gross artifacting on my M1 Studio Max under UE 5.1.0-22491701
Here’s a demonstration:

1 Like

The same for me on Mac Studio. It worked with 5.1 preview 1, but now it’s broken with preview 2.

1 Like