Unreal Engine 5.1 Preview

Hey all,

I have been testing the path tracing fog and decals which has been working lovely for some nice screen shots. I have turned to do some render tests in 5.1 P2 with the movie sequencer and for some reason it does not render the main camera and renders in the 0,0,0 position. I have tested the same scene in 5.0.3 and it works fine. Have any of you had this issue with the sequencer not rendering the correct camera?

1 Like

i heard a rumor pixel depth offset worked with ue5.1… not for the realtime shadows apparently…

I seem to be having issue with 5.1.0 preview 2. project getting corrupted while same actions work fine on 5.0.3

Steps to replicate:

  1. Create Thirdperson template blueprint project
  2. Create any C++ class (in my case Actor class)
  3. Error: Could not find code MyProject.sln
  4. Pressing generate visual studio project button does nothing and visual studio does not open either.
  5. I restart unreal engine, try to re-open project
  6. Get following errror:

Missing MyProject Modules

The following modules are missing or built with a different engine version:

MyProject

Would you like to rebuild them now?

  1. Pressing yes on ‘Would you like to rebuild them now’ results in:

Error

MyProject could not be compiled. Try rebuilding from source manually.

  1. pressing no results in unreal engine closing

There is no .sln file generated,

I tried reinstalling unreal engine, epic games launcher, doing fresh install of visual studio 2019/2022. same result

I have no such issue with 5.0.3 so i assume its issue with preview 2

2 Likes

What about: UE-144539 ?
Love to see chaos vehicle work on Multiplayer :wink:

Same here. I could only create Blueprint project.

How is the performance 5.1 p2 vs 4.27 - my current test same content is that .27 is 60-100 FPS faster using 5.03 even after disabling all the things you need to get them setup the same.

3 Likes

Same here, although with my GPU/CPU the difference is not noticable

What’s noticable however is that UI is kinda janky/unresponsive, whenever I right clicked in editor on something in scene the fpses dropped from 144 to 30 - 60 for second or two

1 Like

Niagara Crashes instantly if you use a User Render Target and check “Inherit User Parameter Settings”

If you are somehow able to save the asset (possible if any stages are not writing/reading form it), you then can’t open it again.

Interesting bug in 5.1 P2.
Messing around with points lights.
For some reason, lights that are occluded (essentially rooms away) cause the GPU to take 500 to 700 ms to render if you have them in the cameras frustum despite being occluded.

Just one point light, it also seems to happen if you have another point light in view even if its enabled or not? It’s very odd…

I noticed if you turn off Real Time thumb nails and keep your content browser on the same monitor the FPS drops go away for me. Normally if I am running the content browser on a second monitor it lowers the FPS. Also if you have the BP open that are in the running level it can get bad.

I know it’s free software and community feedback is important - but can’t you test it yourself before you let loose such a messed up Preview2 on people. Our time is money too.

It’a a magical new hidden feature …

Anybody have success opening a lyra project with 5.1?

macOS Ventura with Metal 3 just released

Metal 3 supports Mesh Shaders

It means that theoretically Unreal Engine developers can upgrade Nanite for macOS. It would be wonderful to have it in 5.1

4 Likes

Niagara Data Interface selection is broken for Simulation Stages in Preview 2. Nothing can be selected when you create a new simulation stage.

Emitter on the Left was serialized in Preview 1 - Emitter on right was created new in Preview 2.

Broken

You have 5.0 and an even more stable 4.27. This is not in defense of Epic, but Preview implies a “volunteer approach” with all consequences.

1 Like

I had the same problem, using European Hornbeam assets, from Quixel. I solved this issue setting up the “Advanced wind” in all materials instances. The movement is looking much better now.

my problem exists on 5 and 4.27 :slight_smile:

And that does no honor to Epic. But a lot depends on how often this problem occurs with other users of the engine and/or how “close” your relations with its developers.

But Preview is Preview, if we’re talking about my original quote.

pretty sure its well known and gauranteed to happen every time. Has to do with pixel depth offset on POM and shadows. Perhaps the shadow casting onto itself never worked properly…