Download

Unreal Engine 4 is now available for FreeBSD

I have developed FreeBSD support for Unreal Engine 4 and have released the source on GitHub as a fork of the main repository.
The engine should run well as a client with NVIDIA drivers, but the server target is the most relevant for FreeBSD.
Currently the fork only targets FreeBSD 11. Precompiled dependencies are only available for x86_64.

Resources
GitHub Repository
Wiki Page

Your repo is set to private

Thanks for letting me know. I didn’t realize that GitHub doesn’t set permissions when using an organization account for the fork. I’ve updated the GitHub link to the new repo and recreated the release. You should be able to access the new repo now.

Tanks for your efforts ! But … repo fives a 404 :frowning: ?

Same here! Returns a Page not found error!
Im also interested on this.

Cool. Does it pre-compile shaders before opening an unreal project? I havent used free bsd in forever. I ran rhel, and now im back on debian, but I prefer yum, rpm, run, and tar.

I have been interested in helping out with a FreeBSD port for a while now but time has been a little bit lacking and the build system that Epic has decided to craft is so vast and custom so there is a lot of framework to navigate before I can even really get started.

On the FreeBSD build wiki page (https://wiki.unrealengine.com/Compiling_For_FreeBSD). It states that “As required libraries for the editor are not available on FreeBSD”.

Can anyone tell me which libraries these are? Are they unavailable because they are closed-source and not ported to FreeBSD or are they simply not yet ported? I can certainly help out with this if it is the latter.

(I tried to make contact on the GitHub page but I cannot seem to find the bug tracker on this repo).