Unreal Engine 4.7 Released!


The 4.7.4 Hotfix is now live! It contains a number of fixes for our latest release, including many crash and Morpheus fixes, all listed below.

If you experience a bug with the 4.7.4 Hotfix, please remember to log a bug report for the issue on the UE4 AnswerHub to the Bug Reports section.

Fixed in 4.7.4

UE-11891 MoveToActor doesn’t update AI’s path on goal actor’s move
UE-11997 Navigation crashing on PIE in absence of NavOctree
UE-12108 [CrashReport] Ensure in UPrimitiveComponent::SetCanEverAffectNavigation()
UE-12106 [CrashReport] Saving after blueprint change causes crash.
UE-12443 [CrashReport] Crash in blueprints during autosave
UE-9417 It is easy to make a comment box unselectable when it overlaps with another comment block
UE-10891 Force deleting a blueprint that is parented to another blueprint causes crash
UE-10865 4.6.1 to 4.7 conversion crash “Assertion failed: Pin != nullptr …K2Node_DynamicCast.cpp]”
UE-11523 DateTime variables will cause a crash on compile
UE-11011 Crash (assert) when accessing a property in a blueprint
UE-12073 [CrashReport] Disconnecting/changing blueprint nodes causes crash.
UE-12206 GitHub 944 : UE-12128: Properly save structs when struct field default value is different
UE-12962 Editor crashes after clicking on “Apply Instance Change to Blueprint” button
UE-10574 Component properties of template not propagated when SpawnActor called
UE-12109 [CrashReport] Crash while attempting to load a project
UE-11368 uv scale of materials on hollow BSP does not persist after building geometry
UE-4743 Crash when moving a sprite imported as part of a spritesheet to another folder if the sprite names had invalid character
UE-11372 Access Violation in UE4Editor_SlateCore!TWeakPtr when changing view options
UE-9824 Widget class is replaced with a placeholder class when reloaded
UE-10040 Copy/Paste a button inside of another button then attempting to move the pasted button crashes editor
UE-11204 Crash when returning to viewport from immersive mode with an editor window tabbed beneath
UE-12915 Crash when using static lighting in foliage
UE-7213 Crash occurred trying to cycle gizmo in Persona Anim BP Viewport
UE-9982 Sprites with non-center pivots can be invisible in thumbnail renders
UE-12196 Automatic collision generation is incorrectly rotated for sprites that were imported as rotated from a sprite sheet
UE-12041 Sprite sheets with modified textures don’t reimport correctly
UE-7918 Sprites don’t initialize PixelsPerUnrealUnit in cooked builds, causing invalid values for GetSocketLocation, etc… for assets that have Pixels/uu of 2.56
UE-11903 Crash closing ElementalDemo game in opengl
UE-12150 Crash launching PIE when sublevel contains landscape in hidden level
UE-12111 [CrashReport] Crash after undoing/deleting landscape.
UE-12433 Editor crashes when toggling off visibility for a sublevel that contains a landscape
UE-11815 [CrashReport] Crash while attempting to connect iOS device.
UE-12165 Morpheus crashes occasionally while running
UE-12209 Canvas items are not drawn correctly in Morpheus
UE-12211 Morpheus tears visibly even when VSync is on.
UE-12212 Morpheus runs HMD distortion shader an extra time.
UE-12324 Morpheus rendering broken when console rendering is on the screen.
UE-11302 Cannot deploy to iPad
UE-12063 Cannot package project on Linux
UE-12210 Morpheus IPD is applied incorrectly.
UE-13048 Xbox projects (code and BP) launch to black screen, logs show success
UE-12213 Landscape material reverts to default when launched onto an Android device
UE-12542 MAC: Very slow texture compression times in Editor
UE-12235 Large performance regression in shadow rendering.
UE-6190 UVs skewed in Mobile Preview mode for some skeletal meshes
UE-11865 Open a level that contains instanced meshes (with built lighting) will crash the editor
UE-10664 Crash in OpenGL3 and OpenGL4 occurs when opening any map after having a map loaded with foliage.
UE-11810 [CrashReport] Crash in ULevel::BuildStreamingData casting Texture
UE-11434 New user crashes on Editor load
UE-12228 Invalid error messages in crashes

Oh nice, another hotfix is out. I haven’t experienced issues with my UE4 instance/project, but pretty cool you are still fixing the 4.7 update.

Hotfix 4.7.4 Out.

Quickly runs to read the changelog.
Scans for bug number (UE-12861)


not there…

Hey Frozen, I looked into that one and it is slated to be fixed for 4.8 with a high priority. It just didn’t make it into the hotfix, but we have plans to fix it shortly. Sorry for the wait.

So just hope there will be a 4.7.5 :cool:

Great update, but I am a little disappointed that UE-11311 did not make it in.
Any time frame for this I was told it was fixed internally, share the goodness. :slight_smile:

And i also have a picture :stuck_out_tongue:


Hi WCode,

It is in the same boat as Frozenfire’s bug. It has been fixed, marked as high priority and is slated to be in 4.8.

If it’s high priority and fixed it would be something for a possible 4.7.5? :rolleyes:

Why do the updates just does not replace things and not re download the whole thing. I just finished installing 4.7.3 after 2 days of download. after 3 seconds 4.7.4 came out suddenly and force me to download 4 gb again. I didn’t even have a chance to open the editor. Question: Is it really forced to update or I just messed something? I don’t see 4.7.3 anymore.

Here’s a launcher bug:

I thought it was re-downloading 4.7.3 again, instead of updating to 4.7.4 :rolleyes:

Ok that is great!

Is Oculus v0.5.0 SDK supported in UE4.7.4 ?

Possibly. Although at this moment we haven’t committed to any plans for a 4.7.5 Hotfix. It also needs to be noted that not every fix can be included in a Hotfix. Some fixes and updates can only be introduced in the major releases because otherwise they may break binary compatibility and some projects for the release version couldn’t be opened any longer.


Restart the launcher before upgrate anything !

Structure default values appear to still not be working properly unfortunately. :frowning:

UE-12206 GitHub 944 : UE-12128: Properly save structs when struct field default value is different

I think it works if you have no inheritance (one BP class with no children). But if you have inherited BPs using these struct and you set the values to new values, then the bug comes back (click compile and some values are zeroed).

I would also like to know when 0.5.0 will be added, any update?

Hi All.
I got problem with new update And new update.
I dont know download which one Version .
when finish download 4.7.3 , New Version Up Coming 4.7.4 and I Cant Use Version 4.7.3 until Download Version 4.7.4.Please Help Me?

I think every minor update to major version is mandatory to re download the whole thing again. I think patching with a less download size should be the updating method.

I’m pretty sure I had the latest version of the launcher :wink:
I opened it to launch the editor and then the update for 4.7.3 showed up. ^^
However, instead of “updating to 4.7.4”, it said “downloading 4.7.3”.
No big deal, it was downloading 4.7.4 anyway and it’s working fine, thanks Epic! :smiley:

That one is fixed internally, but the integration didn’t make it into 4.7.4 in time. It is slated for a 4.8 fix. Please let us know if it is not fixed after the 4.8 release.