Unreal Engine 4.27 Released!

To get foliage to evaluate WPO you need to set r.RayTracing.Geometry.InstancedStaticMeshes.EvaluateWPO to 1 because by default its on 0, no idea why its not on -1 by default. Don’t get your hopes up though, it completely breaks AO and shadows are still inaccurate.

2 Likes

Thanks. This is better than nothing but still “dirty hack”. Not a solution. Shadows are not static now
but mesh still have ugly flicking double self shadows on leaves.


1 Like

Hello,

we are looking on how to embed UE4 as library but it seems that the sample is not embedded according to the page here.

Building Unreal Engine as a Library | Unreal Engine Documentation

1 Like

Hi, have you sovled your problem? And can i ask you a question , hava you finished the first step that successfully built the UELibrary and generated UE4Editor-UELibrary.dll according to the page here ,https://docs.unrealengine.com/4.27/en-US/SharingAndReleasing/Buildasalibrary/? I tried to add the code in the page mentioned above to my project’s *.Target.cs file, to be specific i add the code to UE4Editor.Target.cs file because i choose the Development Editor configuration on Win64. but when i build there are lots of error. i also tried to create my project by UE4 engine and add the code to my myProject.arget.cs, None of these approaches can implement the new feature.

Unfortunately I could not manage to proceed on this front.

Has anybody noticed that 4.27 branch can’t compile? I’ve tried downloading the latest, I’ve updated my visual studio 2019 and installed all the nuget packages, nothing has worked. Check this thread:

In the overview video for 4.27 there was a slide showing still frame rendering with MRQ (around 37:57)

There is a window/tool named “stillrendersetupauto/sequencer still setup” that supposedly automates the still frame sequence setup. However I can’t seem to find this anywhere in UE4.27

Does anyone know where this tool is?

Ping, I’m looking for them too!

Take a look at this

Building Unreal Engine as a Library | Unreal Engine Documentation

I managed to compile as a library by adding to my .Target (the game one, not the editor) the lines on the docs but in order to get the entry points I also needed to add ExtraModuleNames.Add("UELibrary") to my Target.

After that and after switching Rider to “Development” configuration, I was able to compile as a DLL. Had some problems on my code due to the fact that Monolithic Builds seem to have differences in the include (i.e. ParallelFor needs to be explicitly included where used). Also had some problems with MovieScene module, which is used by the Launcher module: this requires the fix I have proposed here: Fix MovieSceneCommonHelpers.cpp in monolithic build by mattiascibien · Pull Request #8357 · EpicGames/UnrealEngine (github.com)

Be sure to check your DLL with an export viewer to verify that it has the exported functions.

If you need anything, just let me know.

1 Like

Thanks for your generous answer. I will try as you told add additional code ExtraModuleNames.Add("UELibrary") to my Target(the game one). In addition, i hope you tell me which Startup project you choose, UnrealBuild Tool or the others and which one you built , the UE4 or MyGame (the game one i created) or the whole solution?

I just used the game project. Did not test embedding though. Only Compilation. I will keep you posted

MyGame
i want to know whether i had some mistakes on creating my own projects ‘MyGame’. I don’t test embedding. I built the source code ,debugged it and started UE4 engine, then i used the UE engine to create my game project as showed in the picture. And then i just right click MyGame and build it , is there anything wrong? :sob: Thank you for your time. :heart:

Seems fine to me. Did you edit the MyGame.Target.cs as stated in the guide and built using UE4 from Github?

yeah, i followed the guide add
GlobalDefinitions.Add(“UE_LIBRARY_ENABLED=1”);
LinkType = TargetLinkType.Monolithic;
bShouldCompileAsDLL = true;
the code to MyGame.Target.cs. and use the UE 4.27.0 release form github. The only thing i’m not sure is which startup project i should choose or it doesn’t matter.configuration

You should not choose one as the output will be a DLL. Just compile it and you will get a dll named after your project (Without UE4Editor- prefix) in your Binaries\Win64 directory.

EDIT: I am testing DLL loading in a Win32 app now but I am still investigating. The dll anyway is called fine.

Thanks very much, i will try by your suggestions and find my fault. I will tell you if there’s any progress.

Hello friend.
You can find enable, visualize Show Plugins Content and Show Engine Content. So, after that locate what you are looking for in Plugin Directory.
I hope this can help you.

There is a bug in the text3d plug-in in 4.27:

Adding text3dcomponent in actor cannot modify visible, and hiding it has no effect

So, was setting up 4.27 source and this happened. I don’t usually get false positives and didn’t have this issue with 4.16 - 4.26. I still have same AV.

@VictorLerp @Amanda.Schade