Download

Unreal Engine 4.26 released!

Can’t find Remote Control Web Interface in plugins.
NodeJS was installed

2 Likes

Looks like this behaviour was indeed modified a fair bit. At least one PR has already been filed relating to this.
https://github.com/EpicGames/UnrealEngine/pull/7364

2 Likes

Switched to flat tessellation(from pn triangles) then cap closed, that was fix for me at least.
Best regards.

1 Like

Thanks for the reply… I can’t seem to get anything to happen when I paint on the BP with mesh paint… hmm.

1 Like

yes. you can use chaos without compiling now

1 Like

It has its own blueprint painting setup, run it using Play in Editor and then select the cloud BP to adjust its settings in realtime.

I don’t know why but density painting doesn’t seem to work, velocity painting does though.

When I tried it in 4.26 preview, density painting worked so… I dunno.

1 Like

tesselation is working on my end. use VertexnormalsWS then multiply that by your texture then multiply that with a parameter set to 10 then convert tesselation multiplier to a parameter and set that to 5 to 25. its still there but seems like normal maps are now inverted oddly :confused:

Crack free displacement works for me if i have VertexnormalsWS as the input. if you are using anything else it does not work.

2 Likes

it is working for me. use the red channel off your normal map instead of rgb

look at my setup in my last post.

1 Like

Congrats on the release, looking really good!

Does anyone know what the reason is for certain effects only rendering in the left eye for VR? Instanced stereo enabled/disabled doesn’t change anything, and things like volumetric clouds, SSGI, and other features are simply missing in the right eye in VR. I’m an experience dev willing to go into the code to get this sorted, but the UE codebase is huge and some pointers would be very much appreciated!

3 Likes

Where can we find the info about nanite, its pros and cons? will it function like tessellation or will we need to learn a whole different method?

I use parameters to change tessellation to add vertex movement like blood going down a wall so it is not just a flat texture. i use it to give depth or bumps appearing on a player after being infected
and other things like this.

1 Like

Pretty much any game code that you have using the existing Destruction stuff via the ApexDestruction module is non-compatible with this release. It’s meant to be deprecated, but it looks like in reality it’s just been disabled completely since none of the classes can be used. Chaos Destruction is available but my guess is it’s going to require some major content/code changes - so be advised if you are planning on upgrading, you are gonna have to embrace Chaos Destruction now.

Not sure if this is an oversight or intentional.



class UE_DEPRECATED(4.26, "APEX is deprecated. Destruction in future will be supported using Chaos Destruction.") UDestructibleMesh : public USkeletalMesh


2 Likes

HW Tessallation is old tech, it’ll be replaced by something better in UE5. By ‘Nanite’ I’m guessing what that translates to is using mesh shaders or something. Not really much info out there yet.

Hey, CodeSpartan

Would you be able to create a bug report detailing the issue you’re having with the richtext, please? :slight_smile: Unreal Engine Community

I noticed that the “delay” no longer works in widgets (not widget components, just widgets) when the game is paused (even if the actor is “tickable when paused”). It worked perfectly in previous versions.

You can no longer call IsInstanceSimulatingPhysics() on an FBodyInstance now, unless you include the “PhysicsCore” module.

The function is Force-Inlined and calls ShouldInstanceSimulatingPhysics(), which is from another module. This looks like an oversight to me, because the linker produces incredibly misleading errors

If you look at the Volumetric Cloud documentation, it’s outlined there where the content lives in the Volumetrics plugin. Unfortunately, videos for BP clouds and painting are broken (which we’ll get fixed) but you you can find the content by following the information there.

Volumetric Clouds | Unreal Engine Documentation

How? I don’t see fracture in modes.

Is there a way to change the Z of a Water Body?

A new tutorial is being posted about Water system few moments ago, so anyone having troubles using the feature that is a plus at YT: https://youtu.be/d5Ft7UaYayM

yeah,me too,I can’t switch nvcloth to chaoscloth.