Download

Unreal Engine 4.26 released!

So I’ve never used movies before but I have a few inside the Content/Movies folder but Unreal is not showing them, when adding filenames manually it says the file does not exist. When using the browse feature to add a startup movie it says MPEG-4 mp4, but mine is h264 codec and that’s also suggested as optimal in the docs.

https://answers.unrealengine.com/que…terrupted.html

I can play these video clips with the media player, np.

If you’re there already… how this plugin is supposed to be used? It’s just about adding meta-data and search for it via this “Search” window?
And how I can add my metadata to the asset? All I see is a greyed out option “Show metadata” in Asset Actions.

4.26.1 - when? :confused:

Just an update summary on GROOMS in 4.26: Issue that needs fixing is Clip Length slider.
Currently in 4.26.0 slider only goes from 0-1, but slider’s “0” and “1” acts as an absolute value of some length…like 0 inch-1 inch.
We want “0” and “1” to be 0% and 100%…where 0, 0.5, 1 would be 0%, 50%, 100% of clip-length…not 0 inch, 0.5 inch, 1 inch of clip-length).
If left as-is, slider NEVER lets you bring Groom back to full clip length. You have to reset Clip Length to default (clicking on arrow), or type in max length manually to get to full length. Please FIX.

THX!

any luck with this?

nDisplay virtual production question:

Any info from Unreal on multi-GPU vs single GPU capabilities for large volumes with several nDisplay machines? Is the 2nd GPU using NVLink limited to only rendering the inner frustum, or could it double the size of a video wall segment, for example?

Hey!
When i trying to edit a default “BP_Sky_sphere” Blueprint in UE4.26 always crashes.
Do you have similar problem?

It seems pretty basic so far, to be honest. If you’re familiar with Everything (a truly invaluable Windows utility; no affiliation), it’s supposed to act somewhat similar to that, but it needs a serious range of filtering options to be really useful. So far I only use it for minor occasional stuff like searching for “TODO” comments in unfinished materials and blueprints, but it could be so much more than that.

In case the plugin’s developer is reading this, it needs at the very least:

  • A counter for search results (“found: 143”).
  • A Content Browser-like “View Options” button (“Filtering Options”?) for filtering/expanding searches (“Include Engine Content”, “Include Plugin Content” tickmarks, and so on). Right now it doesn’t seem to index engine content at all, which is a shortcoming.
  • Some sort of rapid filtering options. I’d personally go with text-based escape sequences like ** , \m, \e, \b, \sm** (textures, materials, enums, blueprints, and static meshes correspondingly), so you could type something like " gold" to immediately filter for gold textures. Basic boolean NOT ("!" or “-”) and OR ("|") operators would be invaluable as well (" gold -goldfinch", " gold | silver").

Anyway, back to your questions: You open the plugin’s search window through Window->Search, and you can setup an asset’s metadata through blueprints. Make an Editor Utility Widget/Blueprint and run the **SetMetadataTag **node for each of the GetSelectedAssets. But again, the plugin doesn’t see these tags right now. Hopefully, it’ll be addressed in future updates.

How the virtual textures work for bigger landscapes. I have baked SVT with 6 streaming levels settings (7 or higher usually run out of memory; having 64Gb RAM). In RVT, using YCoCg with Mask, clear before, packed page, private page, adaptive page, continous page settings enabled (also enabled in landscape material). As actual strange issue, trying to set size of the virtual texture in tiles setting higher (in RVT file), but all values from 8 to 20 gives the same look for landscape as resolution. At one point value 15 still gave higher resolution but no more. What affects that setting to work, is there some poolsize variable that clamp for resolution. Or is SVT causing that. Assuming that SVT is automatically used, while it is selected in RVTVolume and baked (or is there some node to use in landscape material other than RVTSample that reads the RVT file?).

In project settings, having tile size 128, border size 4, feedback resolution factor 32, and both Zlib and Crunch enabled. Virtual texture support enabled, lightmaps disabled. Is there some better setting for those tile size, feedback resolution to use? Tryed testing with different values but changing those requires to compile all shaders in project again.

Its January 18, 2021. Can someone from EG please give some official feedback on the state of GPU Lightmass in 4.26? I am getting LOTs of crashes and when it doesn’t crash is much, much longer than regular baking giving unpredictable results.

Also I can confirm that GPU LM DOES work properly in 4.25 for me.

Is this possibly a hardware issue? I have a Titan Volta card which definitely supports Ray Tracing even though it’s not RTX.

We’re having constant crashes with 4.26 relating to virtual textures / UDIMs. The error is usually related to: VT/TexturePageMap.cpp: line 242. These worked fine in 4.25

Testing lightmapping with virtual textures resulted in lightmaps being written over all the diffuse maps in the project.

Grooms crash with <3 points (easy to rectify once we found the issue but these worked fine in 4.25)

So far 4.26 has been pretty stable for me, overall very satisfied. I do not use lightmass, or virtual textures.

Movie Player Crash
After playing a video file, a packaged project crashes.

Potential Critical Structure Failure Detected
Though, not yet conclusive but it appears that since 4.26, when having a datatable open, and a crash occurs the related DT structure is exposed to corruption. The error is unknown structure in BP_Name, here, stemming from node, get datatable row by name, can be fixed with refreshing these nodes.

this bug has been with us for at least two years or more. The same thing happens if you modify the structure that the data table uses.

That a structure can break upon editor crashing is new to me.

4.26 anti aliasing bug

EDIT: Folks, solution seems to be to update the Voxel plugin if you’re using it. Even though mine referred to a UDS material, removing the voxel plugin solved it. I then updated it, and issue did not come back.

EDIT2: Author of Voxel plugin has now found the actual cause, update forthcoming to clean it up properly.

Hi @SkyeEden, sadly didn’t receive a message back from the report I sent in on this UniformExpressionCache bug, and the current 4.26.1 dev branch also doesn’t fix the issue. Perhaps a long shot, but are you aware of any info on this? I’ve searched the web but only find old bugs with the same crash, nothing current.

Also tagging @MrVinceZ and @Mittens as they had the same issue.

Hi! When using Google Play Services for Android, the game is crashing 80% times when the level changes! If the game is in developer mode, or without internet connection, it’s not crashing.

Hi , 4.26 -> full bug :frowning:
They appear all alone
Why ?
https://i.postimg.cc/WDqpFQc8/Capture.png

NEVER EDIT THE ENGINE CONTENT…
Copy it to your project then edit that copy NOT the orriginal or you will corrupt the engine content…

UE Development Team - a UI item, Cinematic Camera starts off with a default DOF on, presents the visual as blurry.
Make it so that DOF is disabled by default on the Cinematic Camera, or that it is initialized with a sharp presentation of the visual.

Every tutorial video I watch the user adjusts it to compensate for that initial blur, and Newbs are always clueless as to why it looks blurry.
Whatever it is, make it so not initially blurry, otherwise it just pulls you out of the moment that you have to adjust it off every single time.
This confuses newer users. I know because I was one of them, so I will advocate for them here, even though now I am a VIP Expert Level Pro who knows how to deactivate the initial blur.

THX!