Unreal Engine 4.23 Released!

"cast raytraced shadow off " is it working for translucent material? i think not working

While building from source, I came across an error in building which says that it cannot find the include file for <spatialaudioclient.h>, located in MixedRealityInterop.h.

Edit: tried again, same error. It seems to be related to HoloLens. Not sure what to do right now as I cannot use the newest version of the engine from source.

Edit2: Commented out the include and also the line for the function ActivatDynamicSpatialAudioObject() which returns ISpatialAudioObject*. Now I can build from source. Unfortunately, I’m frustrated by the amount of time I wasted to get this to work.

Awesome release sofar no issues Converting from 4.22 to 4.23 just had to adjust some height fog and PP, The new “Actor foliage” is a create addition too. so far my performance seems to be better after some optimization. and Virtual texturing works fine too, also made an Insight comparison with and without VT sofar VT only cost 1ms and saves about 150mb. the new “MaxNetTickRate” also finally got rid of an issue I had for a while :slight_smile:

I also have a tool on the Marketplace that uses the in-editor ticking. Other project that I know also relies on it, so it’s a really unfortunate situation.
For now, the only workaround I’ve found is to create an Editor Utility Widget and run it - this one can tick in editor, but only when it’s opened and in focus, so that’s definitely not ideal.
Dear dev team, please restore the ability to tick in editor for Editor Utility Actors (or any other editor utility actor that can be placed in level), just like the deprecated Placed Editor Utility Base was able to tick.

Any docs on using the native OSC plugin? A basic example would make it a lot easier to get started.

When I create shootergame or content examples 4.23 projects it just sort of does nothing and doesn’t indicate anything (I think the launcher maybe got a little slower afterwards though). Has anyone gotten them to work? The 4.22 versions still create fine from the launcher.

When i compiled the over 3000 shaders for the 4.23 Chaos VS says:

Error C1083 File (Include) cannot be opened: “metahost.h”: No such file or directory UE4 C:\Users\jan-e\Documents\UnrealEngine-4.23\UnrealEngine-4.23\Engine\Source\Editor\SwarmInterface\Private\SwarmInterface.cpp 21

Error MSB3075 The command “…\Build\BatchFiles\Build.bat -Target=“UE4Editor Win64 Development” -Target=“ShaderCompileWorker Win64 Development” -WaitMutex -FromMsBuild” was terminated with code 5. Make sure that you are authorized to execute this command. UE4 C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Microsoft\VC\v160\Microsoft.MakeFile.Targets 44

Anyone an idea how to fix this?

This is could very well kill my market place tool. I wounder what our best course of action is. I just cant understand why they wouldn’t allow ticking in editor. My tool is optimized so it wont slow things down. Controlling tick intervals is not hard to do.

use VS 2017 NOT 2019 and build it from a location that is shorter like c:\unreal

C:\Users\jan-e\Documents\UnrealEngine-4.23\UnrealEngine-4.23\ is way to long of a path

also run the bat file as admin.

When using Physical Light values and Bloom set to Convolution scene gets overexposed… Previous versions were fine when using default values … Now i have to tweak the boost multiplier …
The same is happening with Lens Flares are now too extreme by default…
Also noticed there is a “Enable pre exposure only in the editor” enabled by default, how does this differ from 4.22 is it more expensive now? Because there’s not really a choice but to enable Pre Exposure if you use values past 10000 lux or so…

Reimporting a set of UDIMs instantly crashes the editor.

I’m not sure why the new in editor option is there, maybe to fix some issues with view modes since they all need to be set up for Pre-Exposure individually. There is overhead on the renderthread using it, but I have never profiled it or felt like it impacted much compared to the rest of the scene rendering, but it’s also entirely dependent on the GPU as overflow varies per brand and series. It’s not necessarily *needed *per se, but it can be beneficial to catch any/all issues with overflow on different video cards in which case it would be needed, or you need to reduce the maximum value of the scene.

In “Project Settings / Plugins” I’m not able to see settings for Oculus (Oculus VR plugin is activated by default). In 4.22 it was there.

I posted about what I think is the same error here on page 3:


And also for Preview 8 of the engine:


I think it’s a regression bug that they let slip through, because nobody uses AR/VR from Microsoft at Epic…

There’s nothing special about the output log, except is says it takes 10 seconds:

 LogPlayLevel: PIE: StaticDuplicateObject took: (9.637963s)
LogAIModule: Creating AISystem for world IslandMap
LogPlayLevel: PIE: World Init took: (0.001145s)
LogPlayLevel: PIE: Created PIE world by copying editor world from /Game/Maps/IslandMap.IslandMap to /Game/Maps/UEDPIE_0_IslandMap.IslandMap (9.639402s)

PIE: Play in editor start time for /Game/Maps/UEDPIE_0_IslandMap 10,814

How does this work ??
How can I add per primitive data ??

Is the Light Build progress percentage gone when building lighting? Unreal just freezes until it’s done.

I would like to point out that mirrors effect in 4.23 does NOT work.
Yes I have enabled Ray Tracing.

In 4.23 version there is a bug with buttons in UMG. Color and Opacity setting affects not only the content of a button as mentioned in description, but Background as well. So when I try to set text of a button to black when hovered with this feature, it makes the whole button black. In 4.22 it worked properly and consistent with description.

Yea I did use the new HDRIBackdrop actor in that image.