Unreal Engine 4.23 Released!

try installing to c:\unrealengine
you can’t use long paths like c:\Windows\users
ame\documents\unrealengine etc…

have you tried rebuilding lights?

Yes, afraid this was the result after light build

I’m not having any issues with arrays. however tmaps blow up the editor like a nuke

try deleting the skysphere and re add it and the directional light.

Well i feel like a bit of an idiot now.

Wasnt anything to do with lighting, or even 4.23 at all. My datasmith import is bringing in something called “Global Exposure” from Max now, which is applying a post process that destroys the brightness in the scene. Getting rid of that returned me back to normal. Thanks for trying to help out :slight_smile:

I’m having structs in the arrays. But I’m pretty sure it is a problem of the editor and not the engine. All arrays work as intended when I run the project. I just can’t edit or create new array elements in the editor. So there is still hope ;).

I had one array that threw an error message out. So I investigated and it turned out it contained 82 elements while I entered only 2. There was no loop or anything so I added a ‘clear’ at the start of the node network before adding elements. Then it worked fine. The 80 ghost array elements disappeared. Something weird is going on in the editor only.

Arrays of structures

About the Chaos Demo, it won’t work from Launcher just after download. You need to follow the “new” instructions point out by VictorLerp and build the Chaos Demo along with the Engine from source, and at the document they said you have two options to start the demo: 1) running it inside Visual Studio or 2) double-clicking the .uproject file at Windows Explorer. The second option failed to me, but the 1st one worked so far.

I will work this way, but you can also change the default RHI in the project settings, which will allow you to open the project with DX12 already active, but to enable DXR you will also need to have in project settings Raytracing enabled.

Crash solved :smiley:

■■■■ riva tuner! thx to RSF_Deus.

https://forums.unrealengine.com/development-discussion/rendering/1613122-crashes-with-ray-tracing

So far there have been no problems with the installation path.
From 4.0 to 4.22 always located at: C:\Program Files(x86)\Epic Games\

I got the same issue with path length and had to install it at another path, in my case I used “d:\Epic\4_23”, issue was gone. Compiling it from source will also produce a similar error, so the place you compile the source needs to be short aswel, in my case “d:\GitHub\UnrealEngine”

Definitely something wrong with particle size… Some of my particles disappeared after updating to 4.23.

For me, I can create array varaibles of custom structs in Editor but already had one crash about BP metadara json serialization. So there seems to be something off.

@VictorLerp

-> the provided link is not working in the docs. Can you please fix this, i am curious about RDG

Was the Placed Editor Utility Base class deprecated? I have a child Blueprint that derives from this class and now in 4.23 I’m getting the “(…) has been deprecated” warning on startup. Is there any way to fix this? The “Deprecate” checkbox is greyed out in the blueprint class settings.

Update: I’ve tried reparenting it to Editor Utility Actor, now I can uncheck the “Deprecate”, but now it doesn’t tick in the editor like the Placed Editor Utility Base was. In-editor ticking is very important for my project, how can I restore this functionality?

Update 2: It looks like it can pseudo-tick in editor after using a looping Set Timer by Event, but only when the blueprint is opened in the editor tab. After closing, it doesn’t work anymore, even if it’s placed in an active realtime level.

Update 3: I’ve noticed that the Editor Utility Widgets can tick in editor when opened, so this might be a workaround, but how to automatically open them on map load/editor start?

Hi, just moved my project over to 4.23. Im experiencing a huge loading time (like 10 seconds) when i press play in the editor. Anyone has a idea?

Check output log for errors.

I’ve just tried loading an old project in 4.22 (haven’t even installed 4.23 yet!) and I’m getting this. I suspect the problem has only started since the 4.23 release, as nothing else has changed. Any suggestions?

I have a tool on the marketplace that uses the placed in editor utility base and it requires ticking. Is there anyway around this or an alternative in the newer Utility system?