Download

Unreal Engine 4.20 Preview

Cool! I will try again on the next preview

:slight_smile: Awesome,

Can’t wait for the UE-60858 Clion fix!

Trying to download 4.20 but launcher library only contains 4.19.2. Clicked on + button but that only brings up 4.18, am I missing something?

There is an arrow where the version number appears, which you can click and see the list of all versions including the 4.20 preview

Hi! I have some problems in 4.20 with plugin (spine runtime). When i trying to build project in 4.20 there going errors “Referenced directories does not exist”.
Same project but on 4.19 work fine & build.
As I understand, there is some problem with .build.cs files which has wrong directory definition.

Can anybody say how to solve it?
PS: Ive tried to use in IncludePath full path like 'D:/GitHub/prj/Plugins/Spine and etc", that help to not get errors, but file compile still has errors (the same at with direction errors)nameless.png

Thank you!!

I already reported, fix should be included in the next update: https://issues.unrealengine.com/issue/UE-60969
Just remove this paths from build.cs.

UPD. Please let me know if you could package your plugin (or build -Shipping.lib). I can’t do it even without these warnings.

Thx a lot. I will wait for next preview update.

That’s how binaries changed for engine plugins. I believe it’s related to my problem with packaging plugins for shipping.

Nothing for 2D in a really long time… Paper 2D is barebones and poorly documented. Any plans? Or is 2D a dead affair for Unreal?

Yes, developers stated a long time ago that Paper2D isn’t in active development. So nobody works on this. There are some bug fixes from time to time. That’s it.

Anyone else getting this error when opening their project in the latest 4.20 preview?:

LogObj: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False

It causes my android cook to fail … Doing a Google for bEnableAlphaChannelInPostProcessing comes up empty and I don’t see this set in any of my configs…

I had the same thing in one of my tests, verifying the files fixed the issue for me.

Hey guys, i’m still a bit new to Unreal and Python… but I have been playing with their native Python. Can anyone help me get the selected asset from the content browser via Python? I thought this one would do the trick, but I get an error:

unreal.GlobalEditorUtilityBase.get_selected_assets()

The error is :
TypeError: descriptor ‘get_selected_assets’ of ‘GlobalEditorUtilityBase’ object needs an argument

What type of argument would I need to write to get it to check what I have selected?
Thanks ahead of time, guys :slight_smile:

I’ve already tested the latest master, and it does indeed seem like all of the fixes are working properly.

Thanks just tried it out but unfortunately it does not fix the issue for me :frowning:

MORE INFO: I found how to reproduce it:

  1. Create a AR Template project in 4.19.2 binary
  2. Open project in 4.20P4

Notice you get the error and can no longer build for Android. So it’s related to something in the new AR plugins breaking existing AR projects.

I get a similar error trying to package a shipping build for my AR project for iOS using preview 4. My project was upgraded from 4.19.2 also. Running Verify in the launcher didn’t fix the problem for me either.

This is the iOS package error.


UATHelper: Packaging (iOS):   LogObj: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False
PackagingResults: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False

I’ve tried deleting all the project temp/saved files but that doesn’t fix things.

Hi
I installed the 4th preview of ue 4.2 on Linux. Now i have a problem with lighting that i didn’t in 4.19v. When i open any sample project or import anything to ue, in the lighting mode, everything is totally white! But in the unlit view, textures and colors are fine so i think it’s the problem of lighting. Can you please help me about this?
Here are pictures of my ue:

Getting very strange 13-16ms frame time jumps in PIE or pure game mode (game launched separately) even on fresh empty projects, I have tracked it down to “UI Drawing Time” (this is not Slate/Editor UI) function in the game thread. Any idea how to fix the issue, the root cause of the bug?

I appreciate have an opportunity to test 4.20 (now on preview 4) but it is frustrating to have no notes or sample maps to test features like Proxy meshes or Mixed Reality Framework. For instance, for the Proxy tool, I don’t see any limiting factor notes and it seems to crash on larger static meshes, or was it because the static mesh used displacement?

The Mixed Reality Framework seems less complete than 4.18 with no actual calibration map or function. Also, in the 4.20 P1 version notes, you state that there is a list of compatible cameras, yet in searching I could not come up with one. In my own test, the Logitech C920 works, but my Magewel USB3 HDMI (GEN 1) does not. The MrcVideoSource function sees it and gives me the correct video input of ‘YUV2,1920x1080 60 FPS’ which I have been able to create an instance of M_MrcVideoProcessing and tweak it for my green-screen background, but as soon as I do a ‘VR Preview’ it switches to NV12 640x460 50fps and video freezes, but the rest of the VR experience works normally. There also seems to be an aspect error issue as well, that was not seen in the Logitech C920 video output.