Download

Unreal Engine 4.20 Preview

Hey guys, i’m still a bit new to Unreal and Python… but I have been playing with their native Python. Can anyone help me get the selected asset from the content browser via Python? I thought this one would do the trick, but I get an error:

unreal.GlobalEditorUtilityBase.get_selected_assets()

The error is :
TypeError: descriptor ‘get_selected_assets’ of ‘GlobalEditorUtilityBase’ object needs an argument

What type of argument would I need to write to get it to check what I have selected?
Thanks ahead of time, guys :slight_smile:

I’ve already tested the latest master, and it does indeed seem like all of the fixes are working properly.

Thanks just tried it out but unfortunately it does not fix the issue for me :frowning:

MORE INFO: I found how to reproduce it:

  1. Create a AR Template project in 4.19.2 binary
  2. Open project in 4.20P4

Notice you get the error and can no longer build for Android. So it’s related to something in the new AR plugins breaking existing AR projects.

I get a similar error trying to package a shipping build for my AR project for iOS using preview 4. My project was upgraded from 4.19.2 also. Running Verify in the launcher didn’t fix the problem for me either.

This is the iOS package error.


UATHelper: Packaging (iOS):   LogObj: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False
PackagingResults: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False

I’ve tried deleting all the project temp/saved files but that doesn’t fix things.

Hi
I installed the 4th preview of ue 4.2 on Linux. Now i have a problem with lighting that i didn’t in 4.19v. When i open any sample project or import anything to ue, in the lighting mode, everything is totally white! But in the unlit view, textures and colors are fine so i think it’s the problem of lighting. Can you please help me about this?
Here are pictures of my ue:

Opening Visual Studio 2017 from the editor 4.20 preview 4 gives me this error “LogVSAccessor: Warning: Couldn’t access module table”

Getting very strange 13-16ms frame time jumps in PIE or pure game mode (game launched separately) even on fresh empty projects, I have tracked it down to “UI Drawing Time” (this is not Slate/Editor UI) function in the game thread. Any idea how to fix the issue, the root cause of the bug?

I appreciate have an opportunity to test 4.20 (now on preview 4) but it is frustrating to have no notes or sample maps to test features like Proxy meshes or Mixed Reality Framework. For instance, for the Proxy tool, I don’t see any limiting factor notes and it seems to crash on larger static meshes, or was it because the static mesh used displacement?

The Mixed Reality Framework seems less complete than 4.18 with no actual calibration map or function. Also, in the 4.20 P1 version notes, you state that there is a list of compatible cameras, yet in searching I could not come up with one. In my own test, the Logitech C920 works, but my Magewel USB3 HDMI (GEN 1) does not. The MrcVideoSource function sees it and gives me the correct video input of ‘YUV2,1920x1080 60 FPS’ which I have been able to create an instance of M_MrcVideoProcessing and tweak it for my green-screen background, but as soon as I do a ‘VR Preview’ it switches to NV12 640x460 50fps and video freezes, but the rest of the VR experience works normally. There also seems to be an aspect error issue as well, that was not seen in the Logitech C920 video output.

it might be related to this: https://forums.unrealengine.com/unreal-engine/feedback-for-epic/1457519-4-19-4-20-editor-packaged-games-have-hangs-hiccups-constantly

The fbx, importer on 4.20 isn’t working it just crashes or says unable to load file, just a heads up.

That’s an abstract class and is likely designed for Blutilites rather than Python (it looks like you’d need to derive from it as it’s a non-static function so it’s expecting a “self” argument).

You could try this (untested), which is gross, but I don’t know if there’s another way to get the Content Browser selection right now.


@unreal.uclass()
class MyEditorUtility(unreal.GlobalEditorUtilityBase):
    pass

editor_util = MyEditorUtility()
editor_util.get_selected_assets()

FWIW, the Python “help” command works for our types and will tell you things like their expecting signature, and you can always expose any functionality that is missing by writing custom UFUNCTIONs for it.

That did indeed do what I needed. Thank you so much! I still have a lot to learn, but glad to be learning every day! :slight_smile:

Narrowed it down to the same line as you AtsK. I went to build the engine to check exactly what it is using the 4.20 branch and the issue seems to be gone? Fingers crossed everything works fine in the next preview.

Also I have a feeling this is not the same issue as people are having over in the other post below as I have had no issues at all with 4.19, is that the same for you too Atsk?: 4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly - Unreal Engine Forums

niggers suck fat dick

I’m running into the following error when I try to run a packaged build made with preview 4:


Assertion failed: !GEventDrivenLoaderEnabled [File:D:\Build\++Shared\Sync\Engine\Source\Runtime\Core\Private\Internationalization\TextHistory.cpp] [Line: 1276] 

It’s possible this also occurred in previous previews but due to a different bug I wasn’t actually able to successfully package my project until preview 4. Turning off event driven loading does fix the problem but my understanding is that it improves load times (though I couldn’t find anything definite about this so I may be wrong) so I’d like to keep it enabled if possible.

I’d like to make an official bug report for this but I have no idea where to even start working on a repro case so if anyone has any suggestions/guidance I’d love to hear it. Thanks.

I Agree! Please fix the nvidia hang bugs! :smiley: :wink:

I don’t know who was able to report this for the Mixed Reality Framework plug-in (I am assuming that is what MR means), but I have not been able to find any of the calibration tools or the calibration map from 4.18. I also noticed many of the function calls have been renamed so you cannot use the 4.18 calibration map either. Regardless, I have been able to stumble through locating the Mixed Reality Camera actor and put together a very unpolished tutorial of setting up a camera in your map and then assign a webcam and adjusting parameters for green screen use. However, I still have figured out why I cannot use my Windows Media compatible Magewell V1 HDMI->USB-3 converter. :frowning:

https://youtu.be/y6R0FGrAyXU?t=3611

Hey, this is a known issue and the assert has since been removed. It seems that in some cases EDL can become enabled between the Serialize call, and the call that attempts to process the deferred load action.

Does this mean we can build against C++17? I’m including some third party libraries that use


std:optional

in their interface but building still fails under 4.20 Preview 4.



fatal error C1189: #error:  class template optional is only available with C++17


Any way to make this work? Perhaps passing /std:c++17 to the compiler?

EDIT: So I realized I can probably pass the flag in via the TargetRules’ AdditionalCompilerArguments field, but this requires a Unique build environment. When I set the build environment to ‘Unique’ like so (but make NO other changes);


BuildEnvironment = TargetBuildEnvironment.Unique;

My build fails with;



1>UnrealBuildTool : error : System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\_Development\Repositories\rtg\UE4\rtg_client\Intermediate\Build\Win64\rtg_clientEditor\Development\Launch\Launch.precompiled'.
1>                           at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
1>                           at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
1>                           at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
1>                           at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize, Boolean checkHost)
1>                           at System.IO.File.InternalReadAllText(String path, Encoding encoding, Boolean checkHost)
1>                           at Tools.DotNETCommon.JsonObject.Read(FileReference File) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\DotNETCommon\DotNETUtilities\JsonObject.cs:line 50
1>                           at UnrealBuildTool.PrecompiledManifest.Read(FileReference Location) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\System\PrecompiledManifest.cs:line 37
1>                           at UnrealBuildTool.UEBuildModuleCPP.Compile(ReadOnlyTargetRules Target, UEToolChain ToolChain, CppCompileEnvironment BinaryCompileEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildModuleCPP.cs:line 425
1>                           at UnrealBuildTool.UEBuildBinary.SetupBinaryLinkEnvironment(ReadOnlyTargetRules Target, UEToolChain ToolChain, LinkEnvironment LinkEnvironment, CppCompileEnvironment CompileEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildBinary.cs:line 593
1>                           at UnrealBuildTool.UEBuildBinary.Build(ReadOnlyTargetRules Target, UEToolChain ToolChain, CppCompileEnvironment CompileEnvironment, LinkEnvironment LinkEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildBinary.cs:line 196
1>                           at UnrealBuildTool.UEBuildTarget.Build(BuildConfiguration BuildConfiguration, CPPHeaders Headers, List`1 OutputItems, List`1 UObjectModules, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph, EHotReload HotReload, Boolean bIsAssemblingBuild) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildTarget.cs:line 2323
1>                           at UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String] Arguments, FileReference ProjectFile, Boolean bCatchExceptions) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.cs:line 1480
1>                        (see ../Programs/UnrealBuildTool/Log.txt for full exception trace)
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command ""C:\Program Files\Epic Games\UE_4.20\Engine\Build\BatchFiles\Build.bat" rtg_clientEditor Win64 DebugGame "C:\_Development\Repositories\rtg\UE4\rtg_client\rtg_client.uproject" -WaitMutex -FromMsBuild" exited with code 5. Please verify that you have sufficient rights to run this command.
1>Done building project "rtg_client.vcxproj" -- FAILED.


I’m using a binary build of the engine, not my own built from source. Could this be a reason?

I definitely think the Mixed Reality Framework needs to be setup and documented in a way that its nice and easy to use. Twitch streamers that stream a VR game have to be able to get their camera into there (and have it calibrated correctly) with a few minutes of work, otherwise they won’t do it.

So Epic, please make sure there is proper documentation for that!