Download

Unreal Engine 4.19 Released

"I can’t migrate to 4.19.2

Engine will crash on load. It loads if I delete the entire config folder, but will crash when I try to open my level.
I also have problem with structs that contain another structs and its used on a data table. Lots of errors at the log file saying my soying about userDefinedStructs.

I have no issues at all with 4.18.3"

try deleting your Intermediate directory - always good to do between engine upgrades

p.s quote doesnt seem to work on this forum

Quoting works just fine.

That has never been replicated?

He would be incorrect saying that it worked like that prior to 4.19.

Also setting it on the server dynamically isn’t going to work correctly because the saved movements coming in from the client after that is set will be run at a different speed on the server, causing a momentary hitch when the speed changes.

That is unless it is run on begin play like he had originally.

This is why the characters alter movement speed when crouching and toggle speed during crouch, the crouching flag is passed up from the client to the server in the SavedMovements replication.

Is the black reflection bug fixed for 4.19.2 ?

Hello @Maximum-Dev

I’m personally not familiar with this bug. Have you reported this issue through our Bug Submission Form (recently updated) or do you know the issue number for it on issues.unrealengine.com? If so, please let me know the appropriate information and I’ll look into the status for you. Otherwise, please report it through the form above with the appropriate information and we’ll be happy to take a look.

Hello,

People been discussing it here: https://forums.unrealengine.com/deve…l-lights/page3
I was under the impression that Epic is aware of this.

Will report it right now.
Thank you.

Hi! Sorry for my bad english. When deleting a landscape pin, the engine crashes. This problem has been present since version 4.19. Please fix this.

Please provide the name or a screenshot of the node you are experiencing this with.

Hey Guys!

i Found a bug with capsule shaped Static point lights when sampled by reflection probes:

  • We upgraded project where you need to rotate all your capsule pointlights by 90 degrees to match the lighting, BUT! The reflection capture still captures the previous rotation, resulting in a really strange look (see attached image with only the reflection channel displayed)

  • also many of our bigger levels are crashing when we try to build them (Exterior levels with many small static actors for VR), they were fine in 4.18, 4-5 hours of production bake on a single i7 machine, although it never finishes the lightbuilding process in 4.19.

Is anyone else having issues with multiplayer on the Oculus Rift CV1 in 4.19.x? Whenever we use the Oculus on a client machine, it will hang with a black screen on the HMD for 30 seconds before rendering the level, blocking on a call ovrp_WaitToBeginFrame(). Bug report already submitted, just curious if anyone else is affected. It was working well in 4.15.3, I don’t know if it’s a new regression from 4.19 or from earlier versions.

I reported it but it seems to be marked as a none issue for some reason, Unreal Engine Issues and Bug Tracker (UE-57302)

If Anyone’s interested, our “Big levels fail to bake in 4.19” Error got fixed by checking “Force no Precomputed Lighting”, build lighting (so it clears the deprecated 4.18 builtdata), then rebuild lighting with “Force no Precomputed Lighting” Checked off again, it worked for us!

Fixed!

Can you guys make UE-56261 public? I’m getting extreme hitching on 4.19.1 when I have ‘stat net’ enabled, and I want to see the fix to see if it is related.

HTML5 side always problematic. IES lights don’t work. Performace really poor.
Impossible to make a decent web 3d configurator.
Please make UE4 powerful and efficient exactly how Sketchfab works. At the moment I can’t have the same quality, shaders, and so on…

regards

Is it safe to assume 4.19.2 is coming this week?

When do you plan on launching 4.20 previews ?

Thanks

UPDATE!

The 4.19.2 Hotfix is now live! This hotfix resolves over 40 important issues in the 4.19 release.

**Fixed in 4.19.2 **
Fixed! UE-55065 [CrashReport] UE4Editor_Engine!FExposedValueHandler::Initialize() [animnodebase.cpp:521]
Fixed! UE-57910 Show Angular Limits for Anim Dynamics Node Does Not Show Constraints
Fixed! UE-57097 [CrashReport] UE4Editor_Core!FMath::ComputeBaryCentric2D() [unrealmath.cpp:1951]
Fixed! UE-58232 Show Planar Limit Does Not Show Constraints
Fixed! UE-58227 Show Spherical Limit Does Not Show Constraints
Fixed! UE-51931 [CrashReport] UE4Editor_AnimGraph!FCSPose<FCompactHeapPose>::GetComponentSpaceTransform() [bonepose.h:533]
Fixed! UE-57666 Hang on audio device unplug w/ audio mixer
Fixed! UE-57585 Clicks/pops on PIE shutdown w/ audio mixer
Fixed! UE-58005 Source bus crash
Fixed! UE-58006 Passive mix modifier loop bug
Fixed! UE-58009 GitHub 4678 : Fix crash that occurs when the player controller’s view target is in a sublevel instance that was unloaded
Fixed! UE-58087 Blueprint Map variables with Soft Object values are broken by 4.18 upgrade
Fixed! UE-51952 [CrashReport] UBlueprintGeneratedClass::AddReferencedObjectsInUbergraphFrame()
Fixed! UE-57335 Disabling “Skip Unneeded Dependency Compilation” clears spline points on component compile
Fixed! UE-58115 Crash when removing Blueprint function
Fixed! UE-52921 [CrashReport] UE4Editor_Engine!USceneComponent::DestroyComponent() [scenecomponent.cpp:847]
Fixed! UE-57828 Packaging fails for projects with HTTPChunkInstaller Plugin enabled
Fixed! UE-57427 PerInstanceRandom material expression produces black foliage on editor restart
Fixed! UE-56509 [CrashReport] UE4Editor_CoreUObject!FDuplicateDataWriter::Serialize() [duplicateddatawriter.h:51]
Fixed! UE-57740 Full OS hitches occur while running the editor with statgpu enabled
Fixed! UE-57743 [CrashReport] UE4Editor_UnrealEd!UEditorEngine::BuildReflectionCaptures() [editorengine.cpp:3874]
Fixed! UE-57548 Packaging Fails Due to Camera Cut of Sequencer in 4.19
Fixed! UE-47661 [CrashReport] UE4Editor_Sequencer!FSequencer::NotifyMovieSceneDataChanged()
Fixed! UE-57596 [CrashReport] UE4Editor_MovieScene!FMovieSceneEvaluationTrack::EvaluateStatic() [moviesceneevaluationtrack.cpp:445]
Fixed! UE-57752 [CrashReport] UE4Editor_Sequencer!FSequencerNodeTree::MakeSubTracksAndSectionInterfaces() [sequencernodetree.cpp:268]
Fixed! UE-57950 [CrashReport] UE4Editor_Sequencer!FSectionHandle::GetSectionInterface() [sequencerhotspots.cpp:19]
Fixed! UE-58184 Sequencer: Shot Comprised of Several Shots Set to “Evaluate Subsequences in Isolation” Timeline Does Not Scrub
Fixed! UE-57898 Re-binding unresolved possessables in sequencer leaves stale bindings hanging around
Fixed! UE-55578 [CrashReport] UE4Editor_MaterialEditor!SMaterialLayersFunctionsInstanceTree::UpdateThumbnailMaterial() [smateriallayersfunctionstree.cpp:1128]
Fixed! UE-56272 Incorrect foliage color in editor preview when using PerInstanceRandom node
Fixed! UE-52919 [CrashReport] UE4Editor_Foliage!AInstancedFoliageActor::GetAllInstancesFoliageType() [instancedfoliage.cpp:2244]
Fixed! UE-57594 [CrashReport] UE4Editor_Landscape!FLandscapeComponentSceneProxy::FLandscapeComponentSceneProxy() [landscaperender.cpp:680]
Fixed! UE-56239 Crash when Landscape Max LODLevel is set to 0
Fixed! UE-57276 Crash during save level and successive load level
Fixed! UE-57681 [CrashReport] UE4Editor_Landscape!ULandscapeComponent::PostLoad() [landscape.cpp:657]
Fixed! UE-54547 [CrashReport] UE4Editor_Landscape!FLandscapeVertexFactory::GetStaticBatchElementVisibility() [landscaperender.cpp:1503]
Fixed! UE-57799 Linux: various issues happen due to GStartTime falling out of sync with FPlatform::Seconds()
Fixed! UE-58073 Linux servers cannot start on machines with less than 2G of RAM
Fixed! UE-57588 Adding and removing target in Localization Dashboard leads to crash Assertion failed: (Index >= 0) & (Index < ArrayNum)
Fixed! UE-57086 Material Instance values lost when using Material Parameters inside of multiple Material Functions
Fixed! UE-57817 Incremental build failures with missing symbols

REMEMBER: Please report any new bugs you find by following the How To Report a Bug Guide

Is it possible to update Clang to version 6? New Linux Distris using version 6

Yes I also would like to know when 4.20 previews are starting

Hi guys, I have managed to connect maya live link with success, however it does not let me preview the animations that are in layers of animation within maya only show the “base animation” layer, any idea of how I can solve it ?.

Thank you :slight_smile:

I know the next 4.20 update will be popular in Colorado :wink:

Thanks epic, keep up the great work, will download the latest version soon and test it with my template.