Download

Unreal Engine 4.12 Parallax Occlusion problems

Hello everyone!
So, I have a problem with the node of parallax occlusion. I have decided to provide information about my system, in order the problem has been described more fully.
My system configuration is as follows:
The motherboard - Gigabyte GA-EP43-DS3
Memory - 8 GB
Processor - QuadCore Intel Core 2 Quad Q8300, 2500 MHz (7.5 x 333)
Graphics Card - GeForce GT 630 (I know that this is not the ultimate dream, but there is no money to buy something better)
Operating System - Microsoft Windows 7 Home Premium 64
DirectX - DirectX 11.0
The problem is this: node parallax occlusion did not seem to “see” the heightmap, the depth of the effect on objects with this shader I have not seen. At the same time shader with tessellation it works fine. In addition, I asked a colleague to take my shader and test it at home, on his computer. Here is a video

which shows that my shader with the same settings on a different system work.

And this how the shader looks in the editor on my computer:

You can see that heightmap is not work. I can set “Height” parameter in my shader to any value, and it is don’t change anything.

The system configuration of my colleagues:

The motherboard - Asus P8P67 LE
Processor - i7 2600k
Memory - 32 GB
Video - Gigabyte GeForce GTX 1070
Operating System - Microsoft Windows 7
DirectX - DirectX 11.0

I hope that it is possible get to work the parallax shader, on my system, and therefore decided to ask for help to solve the problem. Here shader screenshots66cb7b850e5abfd951786decae6886138bf4272a.png
I made according to this tutorial:https://wiki.unrealengine.com/Parallax_Occlusion_Mapping

In addition, this quality settings display in the editor:
scalability.png

In these screenshots (1 and 2) is shown as I was trying to to bypass a quality switch:
QualitySwitchFull.jpg

This all seemed to be, if I forgot something, you can call me bad names, it will be fully deserved. :slight_smile:

What are your engine scalability settings in the editor?

For purity of experiment, you could bypass quality switches also. Maybe you material quality level is set too low?

If not, can you confirm that simple bump offset node is working for you?

Hi! Thanks for the answer! I will try this evening to make shader with a bump offset and lay out the results. Engine scalability settings I put on “Epic”

scalability.png

About the quality of the material switch I did not even know, I’ll try and put it also in a higher value.

Can you try loading the project Content Examples and open the Parallax Occlusion Mapping level there? There are a bunch of examples so it will be interesting to see if those work.

(edit: saw you specified dx11 already. doh). Also just to double check, are you running in DirectX 11 or opengl? should be under project settings->platforms->windows

One minor thing but I don’t think is the cause of your problem: You are using my tempAA trick to dither the steps, but the values on the Lerp node are wrong. The A input of the Lerp node should be set to 1 instead of 0. Again I don’t think thats causing your main issue but it will cause the POM to be extremely fuzzy looking.

You guys are just great! I do not know what I would do without you. Indeed, the whole point was that the materials quality level was set to “Low”, this was all about. You can just call me “stupid russian”. If you ever need help, just say: “Hey, you stupid russian!”, and I’ll be right there.
It remains to deal with shadows in the parallax node, and I can move on and make houses.
Ryan, thank you too for that responded to my question, I checked the the unit with DitherTemporalAA because parallax was noisy, and now everything is OK.
Thanks a lot, everyone!
P.S.
As noted in this forum that the issue has been resolved? I do not often go to sites on English especially. And for a snack:
https://youtube.com/watch?v=uelQXrgYfFk

Glad you got it sorted.
These days, I suggest people try out the new Contact Shadows feature that was added in 4.13. It can add self shadows from POM without any cost! you just need to use stationary or dynamic lights.

I just tested the contact shadows (didn’t know it was already in 4.13). Fantastic feature. Helps a lot for light leaks in my 100% dynamic architecture scene!

It seems it is time to install a new version of the Unreal Engine. Thank you Ryan!