Download

Unreal Engine 4.10 Released!

Right now, the ticket for this (UE-21858) is listed as fixed and targeting the 4.10.1 hotfix, but this ticket has yet to be verified and closed since we’ve not got a build of 4.10.1 to test on just yet. If all goes well this should be in a hot fix, but I cannot guarantee until it’s tested. If not 4.10.1 it should make 4.11.

Thanks, glad it’s fixed! :slight_smile:

It’s really sad that a such a big bug is already live for two full UE4 Versions… I’m still at 4.83 because of this bug.

Probably not the best place to post this, but I’m getting hundreds of “This map is using externally referenced packages which won’t be found when in a game and all references will be broken” map errors on every 4.7-4.9 project opened in 4.10. I never had this problem after updating to 4.8 or 4.9, so it may be relevant to this release. I’ll try to detail the issue on AnswerHub after I figure out what exact conditions trigger it, but right now I’m still trying to get rid of the errors, since the trick with renaming the project folder doesn’t seem to help.

EDIT: It seems that the errors may have been caused by changed DerivedDataCache entries in updated BaseEngine.ini, so my apologies for this premature bug report. I’m not usually the one to panic, but the sheer number of seemingly uncorrectable map errors overwhelmed me. :o

nvm

/10chars

Hey,
Just rename your project folder to something else and re open it from the launcher.

Cheers!

Edit:oooops, i didnt read until the end. My bad. Sorry.

I am currently working with someone on answers unreal to try to fix my 4.10 not able to build… getting build failed every time on any project… Even simple ones instantly…

Now i tried building MY project on another computer that allows the build to work, but when i got back to my computer it had no unreal editor open and it had a windows error about closing lightmass because not enough memory or something. Why cant you guys make a stable release???

4.8 broke screen space reflections in my project… 4.9 broke my ability to network build between multiple comps with swarm… 4.10 my main comp is build failed or a crash, and my work comp runs out of memory… 12 gb of ram… 6 gb of ram was enough to build this on another comp in 4.9…

I really think you guys need to take some manpower away from adding new sellable features… and make the engine actually WORK. I am sorry if i seem angry. I am. I am wasting way too much time and money.

PS. screenspace reflections still dont work in 4.10 for me (They are black)… and net work build i cant even test because… yea… i cant build at all.

I post on answers unreal constantly, but the only reason im posting here is to maybe… just maybe light a fire under someones a**. Thanks.

And dont get me started on performance issues… i can be in a room with 200 draw calls staring at a wall… if i move my camera back and forth while still looking at that wall… it raises to like 2000 draw calls but if i hold still it falls really quick to 200… causing massive lag spikes anywhere in my scene if i rotate the camera… as though it doesnt cull properly… and takes everything into account for a moment until u stop moving…

I fixed this by renaming my project to the original name by removing the “4.10” that the project conversion adds to the folder name.

thanks for this @everynone… good that it was mentioned :slight_smile:

Getting the same. Please fix this Epic!

After getting new computer (i7-5820K, 32Gt DDR2400, Asus X99-A + GTX780, SSD, Win10 64bit from old comp) I am getting strange stutter issues with 4.10. Often when play-testing project I get instantly heavy stutter when pressing F11 to get bigger window. FPS goes bellow 10, while normally it should be over 50 in that big window. Also in editor there is suddent stutter time to time that go away if minimizing editor and getting back (sometimes need to do it ~3 times). Also crashed once during the stutter. CPU usage seem to drop from ~25% to ~8% during the stutter. Suspecting there is some power saving issue, but I have disabled the one in win10 setting and also changed BIOS setting to more performance setting. Not having issues with other games (tested witcher3, fallout4, men of war assault squad 2) and dxdiag/NVIDIA look normal.

HI SaOK,

Can you post this in the Bug Reports section of the **AnswerHub**and we can investigate there? Make sure to include as much detail as possible and any additional notes that would help reproduce the issue. If you still have 4.9 installed it would be helpful to know what results you’re seeing in that build as well.

Doing a quick test on my machine with 4.10 mine hits the 120 locked FPS without any problem in standard view and then in F11-full screen I am getting a consistent 113 FPS.

This is my work system specs:
OS: Windows 8.1
PROCESSOR: Intel(R) Xeon(R) CPU E5-2620 @ 2.10GHz
MEMORY: 32GB RAM
GRAPHICS: NVIDIA GeForce GTX 680

Thank you!

Tim

Hi, :slight_smile: made ticket here and seems like there is somekind leak with win10:
https://answers.unrealengine.com/questions/337285/fps-get-close-to-1-when-pressing-f11.html

Would test with 4.9 but worked long already with 4.10 and dont have it installed. But will let you know if finding more clues. :wink:

Param.sfo seems to get overwritten by some default file during the build process, so my changes are reset.

Any idea why?

unreal 4 is sucks !!!

3d Widget 4.10 not responding

3d widget does not respond interaction on 4.10, I had the same issue on 4.9.
Also OnBeginCursorOver/OnEndCursorOver Event does not work. I spent ages
trying to figure it out with no joy. It does work find on 4.8 though.

Hi Maslobojik,

I’m sorry to hear you are unhappy with the engine. Is there anything in particular you are not satisfied with? Are there specific areas within the editor that are trouble spots for you? If so, is it bug related or are you having difficulty using a specific editor feature, have you had a look at our documentation?

The answerhub can be useful for bug reporting or if you are having difficulty with the editor in general.

The documentation is extremely helpful when learning various aspects of the editor and can be a great resource for picking up a variety of concepts and ideas.

You can also find useful information on our wiki. There are many fantastic tutorials already uploaded here if you want to take a look.

If you have any specific feedback on the editor and what can be improved, please feel free to make a post on the Feedback section of the forums.

Hi SIGage and Froffs,

Unfortunately we’ll need a bit more information before we’ll be able to assess what is occurring. If you could, please post to the answerhub (link in signature) so we can assist you more in depth. In your answerhub post, please include what steps you are taking to reproduce this on your end as well as whether this occurs in a clean, blank project with no additional content or if it is limited to one project.

Please post this to the answerhub in the bug reports section as well, though the first few things I would check would be whether you have set the input to Game mode and UI, UI only, or Game only; whether or not you have set the widget components to consume input, and if you have enabled input from the player on the 3D widget.

Hey Adam, this issue has been posted multiple times on Answerhub and on forums, I’ve even created a thread with collection of related answerhub posts and current ticket number Can't interact with 3d UMG widgets - Feedback for Unreal Engine team - Unreal Engine Forums , yet it completely ignored.
edit: And now I’m ignored here too, nice. :wink:

Getting a ton of crashes (so far I’ve only done widget work) if I dont have all the toolpanes open in the editor (IE if I have animation or timeline closed it’ll crash). Not going to submit a AH bug report, first gonnna try reinstalling when I have time but very annoying, might downgrade for the first time ever.