Unreal Editor viewport BUG - Flat icons and unredered assets


I have a problem with my UE4 viewport. Using version 4.15.1.
Everything was working fine, but I have this weird bug and my project is completely messed up.

I haven’t changed anything to the files.
So basically when I open the file, most of my assets aren’t showing up and the icons are all FLAT !

Can you please help me?


I had same problem, I posted it elsewhere, no answer. I think problem was in bad mesh or bad material settings, but maybe just bug. Anyway, only solutions in my case was:

  1. do backup - if you don’t know how to backup your project, don’t read next points;
  2. remove all directory inside project other than CONTENT - again - do not remove content directory
  3. start your project.

You will lose your project settings and bindings - if any, but you can run it and visual side will be ok. You can also not remove your bindings file or copy it later from your backup file if important.

If somebody know better solution - please tell me, upvote waiting in my questions.

Thank you for your answer, will try it out.

I did update my graphics cards driver by the way, and other projects work fine under 4.15.
I don’t know what could have caused this graphical issue.
Will keep updated and hopefully sort this out.

Hard to say, what making problem, but it never happens before 4.15 on my PC. I have many small test projects for different game parts, and some had this problem. Good luck.

Hey Vaheva,

I have seen this issue before, and in my experience this issue occurs when you set the Near Clip Plane within your project settings to 0.0. Check this setting to see if that is the case. The default value is 10.0 which works well in most cases. If you need to modify that value, I would stay away from 0.0 as that is expected to cause issues.

Let me know if you need further assistance.


Hi. I not need to check - I removed this project already, but I bet this is reason! :slight_smile: This is possible, because I changed it when my weapon was too close to camera on animation. In current project I have it 10, and no problems. Thank’s for advice!

You can answer on my question, I will approve it, or I will close it in next two days.

Thank you!

Thank you so much Andrew !

Indeed it was the clip plane value, reset it to default (10) and problem gone.


Hey ,
Yes it’s because of clipping issue. It’s work thanks alot.