Unreal Editor crashes when creating new project (v 4.13 and 4.14)

I’m running osx Sierra v 10.12.2 on a macbook pro and have tried creating new projects in Unreal Editor but have gotten the same kind of errors. I started with UE v 4.14, saw the error, and then uninstalled and tried it with 4.13 because a thread here suggested that as a solution.

This is the error text:

Running Mono…

Setting up Mono
/Users/Shared/UnrealEngine/4.13/Engine /Users/Shared/UnrealEngine/4.13/Engine/Binaries/Mac
Discovering modules, targets and source code for project…
Compiling with non-standard Xcode (xcode-select): /Library/Developer/CommandLineTools/
Triggered an exception while looking for SDK directory in Xcode.app
System.IO.DirectoryNotFoundException: Directory ‘/Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs’ not found.
at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) [0x00000] in :0
at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in :0
at System.IO.Directory.GetDirectories (System.String path, System.String searchPattern) [0x00000] in :0
at System.IO.Directory.GetDirectories (System.String path) [0x00000] in :0
at UnrealBuildTool.AppleToolChain.SelectSDK (System.String BaseSDKDir, System.String OSPrefix, System.String& PlatformSDKVersion, Boolean bVerbose) [0x00000] in :0
ERROR: Invalid SDK MacOSX.sdk, not found in /Library/Developer/CommandLineTools/Platforms/MacOSX.platform/Developer/SDKs

If anyone has any idea for how to make this work, I’m all ears. Thanks!

I wanted to bump this again now that the holidays are over. Any help or suggestions would be hugely appreciated. Thanks!

This has been solved now. There was an issue with Xcode in preferences >> Locations. The option for ‘Command Line Tools:’ was blank, and when I selected ‘Xcode 8.2.1 (8C1002)’ and closed the preferences, things worked fine.