Unreal Accessor (Source code) not connecting to visual Studio


I am trying to Install Visual studio 2019 on my UE 4.27 but it is not working as expected.

  1. I tried to generate visual studio project files → Not working because no C++ inside the project
  2. I tried to create a C++ asset → Not working because no compilor
  3. I tried to change the accessor source code editor → Not finding my Visual studio version

I already uninstall both Visual studio and UE, nothing change.

Do you have an idea of what I can do to solve this ?
Thanks a lot.

1 Like


Just to cover all of the bases, have you followed the set up guide for Visual Studios when installing? It could be that a step was missed while installing.

Setting Up Visual Studio


Hi @Quetzalcodename ! :grinning:

I have no access to this link. I followed the step I found online, but can check again, cost nothing. Thank you for the tips.

1 Like

Oh no! Please try that link again @OAFTLeS, I just corrected it! :smiley:

1 Like

I already followed this support, I will re-do it again but I am not so much confident about this.

1 Like

Just doing the install:

And I cannot ceate a C++ project:

1 Like

I think may see what is happening @OAFTLeS. Unreal does not create a C++ project outright. Instead you would select your project template and click next:

Then in the next menu, you would select C++ from the dropdown menu you get when you click on Blueprints:

I hope this solution is what you need!

1 Like

Yes, my bad on this one !

So on a new project it works perfectly, but on an old one, I cannot link to visual project.

1 Like

@Quetzalcodename I think I found it ! The plug in visual studio wasn’t activated in the old projects when it was in the new. Everything works.