Unreal 5 Build crash aqProf.dll VtuneApi.dll

Hello, I simply created a FPS projet, then try to build the projet then it crashes. Here is the log:

Here is the first part of my error log:

Log file open, 04/05/22 13:26:57
LogWindows: Failed to load ‘aqProf.dll’ (GetLastError=126)
LogWindows: File ‘aqProf.dll’ does not exist
LogProfilingDebugging: Loading WinPixEventRuntime.dll for PIX profiling (from …/…/…/Engine/Binaries/ThirdParty/Windows/WinPixEventRuntime/x64).
LogWindows: Failed to load ‘VtuneApi.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi.dll’ does not exist
LogWindows: Failed to load ‘VtuneApi32e.dll’ (GetLastError=126)
LogWindows: File ‘VtuneApi32e.dll’ does not exist
LogWindows: Started CrashReportClient (pid=21644)
LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.
LogConsoleResponse: Display: Failed to find resolution value strings in scalability ini. Falling back to default.
LogInit: Display: Running engine for game: MyProjectUE5
LogCore: UnrealTraceServer: Trace store launch successful
LogCsvProfiler: Display: Metadata set : platform=“Windows”
LogCsvProfiler: Display: Metadata set : config=“Development”
LogCsvProfiler: Display: Metadata set : buildversion="++UE5+Release-5.0-CL-19505902"
LogCsvProfiler: Display: Metadata set : engineversion=“5.0.0-19505902+++UE5+Release-5.0”
LogCsvProfiler: Display: Metadata set : commandline="" “C:/Users/cb/Desktop/Tuto Gaming/Unreal/Unreal5/MyProjectUE5/MyProjectUE5.uproject” -EpicPortal -epicusername=M.Chat -epicuserid=b1a5ae1ae5af4b689566ec183d006bea -epiclocale=en -epicsandboxid=ue""
LogCsvProfiler: Display: Metadata set : os="Windows 11 (21H2) "
LogCsvProfiler: Display: Metadata set : cpu=“GenuineIntel|Intel(R) Core™ i7-9700 CPU @ 3.00GHz”
LogCsvProfiler: Display: Metadata set : pgoenabled=“0”
LogCsvProfiler: Display: Metadata set : loginid=“492b47a84afaaef19a050d81eb88d996”
LogCsvProfiler: Display: Metadata set : llm=“0”
LogPlatformFile: Not using cached read wrapper
LogStats: Stats thread started at 0.226597

1 Like

I’m experiencing with the same issue. You got any solve?

Same here,

I’m experiencing with the same issue.

I’m also getting a similar error. I found some old UE4 threads saying the solution might be rebuilding the source code or starting a new project and copying the Contents folder over to it. I’ll attempt some of these methods, and report back.

[Edit] Nope, neither of those things helped.

I might try some of those sketchy third party .dll installers to see if that works. It is weird that there seems to be barely any documentation on them.

Still the same… Did you success with manual dll install ?

have you tried using DirectX11 as an option in UE

I just tried… nothing, still crashing.

Deleting the DerivedDataCache was suggested to me in another thread. I’m trying it now.

It did nothing.

1 Like

Okay, I’m not sure which of these things I did made it work, but I can do things now. The things I did:

I turned off Lumen in Project Settings. I switched it from virtual shadows to real shadows in Project Settings. Further down on my log it was saying shaders for some files I did not care about were causing other errors, so I went to the whole containing folder in Windows Explorer and deleted it. I turned off the Windows PIX GPU Plugin.

TBH, I think it was the deleting that folder with the shader errors. My guess is conversion to UE5 corrupted those files.

1 Like

have same error…I really hope someone give me a solution, it has been torturing me for weeks. :sob: :sob: :sob: :sob: :sob:

1 Like

my project has crashed at the same problem. through checking the build.cs file, I found a word got wrong. After I correct it, the problem gone. hope this is helpful.

Hello this can happen when you delete stuff from your project and the editor tries to launch them in the node spawner (I think)

you need to navigate to your users AppData → Local → Unreal Engine → {Engine.Version}

delete all of it check other folders too not just local!

the error will be gone :slight_smile:

2 Likes

That sounds like a method that will work. I’d really appreciate if you can specify which .build.cs file you edit.

Has anyone figured out how to fix this problem? I have done everything to try and fix this problem. I have even deleted unreal from my computer, I then reinstalled windows and unreal and after starting unreal 5.2 back up with new clean install after about an hour I have started getting this message again. Does anyone have a solution to fix this?

visual studio debug run and try it again.

i did “Fix Up Redirects” and it worked for me

1 Like

Solution i found work 100%
If you can’t start the engine, delete all others folder in you project folder, except “Content”
When you able to start engine, this first thing to do is highlight the “Content” Folder in engine “Right click” and " Fix up Redirects"

Hope its help for everyone. Cheers

1 Like

It’s a old post, but I just had this issue, in my case I wasn’t being able to even enter the project, this is how I fixed:

I deleted the “DefaultEngine.ini” from the sub-folder “Config” on the project folder.

After that my project launched, and I saw that what was causing the error was that I had setup some watch points on the animblue print of some characters placed on the start map, after I removed the watchpoints from the nodes, the map was working fine, I closed the project, restored the “DefaultEngine.ini” and everything is peachy.
To avoid this problem I guess you better not debug anything from the starting map.

Thanks for the help and just to add I got this error and managed to fix it: I hope some of the below helps.

I would recommend only doing one of these steps at a time and then repackage - as I am not completely sure which one it was, but I think it was related to metahuman plugin.

Also (if not done so already) make a back-up of your project before you do the below:

  1. I had another error in the log that I found out was in relation to the metahuman plugin. So, I deactivated the metahuman plugin (they do still work - but you don’t get the advanced animation features, Of course, if you don’t have this plugin activated skip this step).

  2. I deleted the files in the Unreal 5.2 (my version I was using) folder in the C:/Users/{system username}/AppData/Local/UnrealEngine

(As noted in this post Although I didn’t actually rebuild afterwards though at this step: Call unknown Function Error ! (aqProf.dll related and selffixed) - #5 by EatVege-tarians)

  1. Deleted Folders: saved, intermediate and config.
    Please note - Deleting config files can alter many settings, so keep a backup if you do this as you will need to configure them again if you changed anything in any of the config files.

  2. Deleted Binary folder:
    You will likely get a warning project needs to be rebuilt, but if you load project it should do this automatically and you have to wait some time without any notice it’s building. Again, keep this folder backed up in-case the project doesn’t work after you do this step.

1 Like