Unreal 5.0.2 causes my M1 Mac Studio to crash

Hi,

Unreal 5.0.2 (and also previously 5.0.1 ) keeps crashing my Mac Studio (Ultra). Without any reason Unreal freezes and my hole machine with it and I need to restart. Never had that before. Crashes of Unreal 5.x? Yes, but not that it pulls my system into limbo as well.

I tried it with new, clean projects, a new installation of Unreal, the Epic Launcher and even my whole system. No joy.

Anybody with an idea?

My specs are: Mac Studio Ultra / macOS Monterey 12.4 / 64 Gb Ram

Thanks in advance

I’m sorry to hear this. Now I am hesitating to update on my M1Max MacBook Pro

1 Like

Thanks. Maybe it‘s just a problem on my end. Don‘t let this spook you away from that great machine :slight_smile:

2 Likes

I have the same problem. Mac Studio Ultra. Freezes and machine restarts.

Same problem here. Mac Studio Ultra, completely freezes up. 4.27.2/5.0.1 & 5.0.2. Freezes the entire operating system, not just the unreal program. Only way to recover has been to reboot with the power button.

I set up a secondary monitor and moved the MAC Force Quit Application to that screen. Unable to force quit Unreal Editor when the application freezes.

Have also tried detaching and reattaching the monitor when Unreal freezes. This appears to force the MAC to sleep and requires you to log in again. Also forces the Unreal editor to quit.

Also enabling (Security & Privacy/firewall/allow incoming connections) for Unreal Engine, EpicWebHelper & Epic Games Launcher. UE5 still freezes machine.

Tried turning off firewall completely and Unreal still freezes.

*Note. Mouse disappears when program freezes, however if you have two screens set up the mouse and OS will continue to work on the screen not displaying the UE editor, but unfortunately force quitting the application does not work.

1 Like

Hi, have the same issue on my Mac Studio M1 Max.
Does anybody know how to fix this???

Just an update that I updated to 5.0.2 and did not have this problem on my MacBook Pro

Good to hear it works for you. It does not work for me though. I start to believe it has something to do with the combination Mac Studio/UE 5 cause all worked smoothly on my M1 MacBook before.

I also have this problem with a Mac Studio (Ultra).

I’m brainstorming a possible solution to your problem with the M1Ultra crashing (I don’t have one myself): perhaps go into your Config folder and inside DefaultEngine.ini and under the [/Script/MacTargetPlatform.MacTargetSettings] heading just delete all the lines there.

Thanks for the brainstorming. I will try that. It only can get better :slight_smile:

Tried this, no result.

It seems to crash random, sometimes adding first object, other times I can use if for 20 minutes until it crashes. I see no pattern here. :frowning:

Yes, same here. I first thought it crashes under heavy CPU load, but it also happens under random circumstances.

It seems like that disconnecting the Apple Studio Display (connected via USB-C) helps to end the freeze for me. At least the last few times I tried. Anybody an idea why this works? :slight_smile:

Hi Everyone,

One of our customers has exactly the same problem with unreal engine (Soft : TwinMotion) and Mac Studio in macOS 12.4

I " potentially " solved this error by activating the Vsync in options (On the soft)

Hey y’all. I’ve bumped this up to the “Feedback for the Unreal Engine Team” category and not the “Feedback about Unreal Online Learning.” This is a better discussion for that category.

1 Like

Thanks! I’m a real forum noob. :slight_smile:

3 Likes

Same behavior on my Mac Studio M1 Max, MacOS Monterey 12.4 + Unreal 5.0.2
Unreal freezes randomly, but when I disconnect and connect again my monitor, everything works again… :astonished:

I have found a very weird “workaround”. I connected my Mac Book M1 13 to another USB-C port of my Mac Studio and set it up as a second screen. Now UE is not freezing my system any longer.

Don’t ask me why or if this works for anybody else, but I’m glad that I’m for now - fingers crossed - be able to work with UE until this problem is solved on Epics end.

Hi everyone!

I’m facing the same issue, I just bought a mac studio for a time sensitive project only to get it crash as soon as I open Unreal.

imDapi: I’m new to Unreal as well. Could you please share some instructions on how to activate Vsync? I tried some tutorials but they’re all for Unreal 4.

Thank you!