Unreal 4.5 not picking up Oculus Rift.

Anyone else having trouble with this? I’ve been working on a project in 4.4 and when I run the standalone game it works with the rift after going fullscreen as expected.

After opening the same project in 4.5, after going in to full screen, it doesn’t pick up the rift at all, and the “stereo on” console command doesn’t do anything either. I’ve also tried opening up other projects like Couch Knights, but none of them seem to work in 4.5, everything is fine in 4.4 though.

Is there a different process for enabling HMDs now?


Hey Scty-

Are you able to create a new 4.5 project (Blueprint First Person) and run that in standalone? You should still be able to use Alt+Enter to enter Oculus mode. Also, if you right click the .uproject file in the project folder you can switch the engine version to open a 4.4 specific project, such as Couch Knights, in 4.5.


Hey thanks for the reply, sorry I only just got back to work on this.

I’ve just opened up a new 4.5 project, using the Blueprint First Person template, and after running it on standalone it still doesn’t go into rift mode, it also doesn’t even go full screen, it just fills the top left corner like this:

If I do the same thing on 4.4 it works fine. Also any project that I open in 4.5, even couch knights doesn’t enter rift mode, just does the same thing and fills the top left corner of the screen.

Any suggestions?


Oh my gosh I am such an idiot, I just checked my SDK and realised that I haven’t installed 0.4.2 on this computer, DERP!

It’s working perfectly now, thank you!

I had this issue too, but I actually develop for UE4 on a different machine than the computer that I use my oculus on. After much frustration I installed the oculus runtime on the dev machine and then the demos worked. Not sure if this is intentional by Epic, 4.4 worked fine creating demos without having the runtime installed.