Download

Unmapped texels (causing lightbuild to go slow)

I like my scenes/objects to be as clean and performant as possible Still learning UE4 (who isn’t), also still learning UV unwrapping (C4D) as I never learned it properly.

I have this rainpipe modelled in C4D, I think I have a clean UV map (see screenshot) before I bring the object into UE4 , the building process takes a good while. Looking at the reasons why this is taking so long I get the results in the white box (see screenshot) … What are all those unmapped texels ?

I have to admit - I’m getting this result after I cranked the lightmap resolution on the object upto 512 (not sure why I felt the need to do this - I thought the shadows looked a little off, not sure if it’s due to the resolution of the lightmap.)

When I’m putting it back to 64, I only get .2% unmapped texels, but still , I’d love to know where those “unmapped texels” are and how I can get them down to 0% , if possible.

Any help greatly appreciated.

905c5e9d48c3bdeec7bcfdcdfac58106a10cc0e9.jpeg

If you haven’t changed the importer to create lightmap uv’s, it will create a new set, and make that the default lightmap layer. So your nicely laid out on may not be used.

Thanks for your input.
Just to make sure, what you meant to say was:
Try to uncheck the box that says “generate uv map” when importing the mesh.
Right ?

I did that and not much has changed.
rainpipe-solo_nu is the mesh that I imported with the option to create UV map UNCHECKED
rainpipe-solo_tmp is the mesh that I imported earlier with that option CHECKED, so Unreal should be creating new UV map

both rainpipes also look the same when rendered.

Screen Shot 2016-02-15 at 19.42.46.png

Probably you’ve solved this by now, but if not I’ve written about unmapped texels (and why they are so important) on my blog http://niberspace.com/blog/speed-up-ue4-lightmap-build-times/