Unknown exception - code 00000001

My project has started crashing randomly both at launching and opening the editor. I’m using 4.8.3 and built off of the rift template. The project is also based on blueprints with little to no custom c++ scripts. link text

Hi Lobohotpants,

  • Does this occur in a clean, blank project with no additional content or is it limited to the Rift template?
  • Can you post your crash callstack here so I can take a look?
  • What steps are you taking to reproduce this on your end?
  • Can you post your dxdiag here so I may take a look?
  • Are you using a VR headset? Do you have this connected to your pc and/or have the program running when you experience this crash or do you get the crash even when it is just your pc without the headset/software running?
  • You said little to no custom C++, if you have any, what c++ scripts have you added? Are they custom c++ classes or are they changes to the engine in any way?
  • Are you using the Github or Launcher version of the editor?
  • I haven’t been able to make a blank project crash or even a basic rift template project. It only seems to crash in my current project
  • See below
  • It crashes when I run it in VR preview mode or launch the game from the project file
  • See below
  • I’m using the DK2 headset. It only crashes when it’s trying to switch to the oculus.
  • I’m using the rift template and the kinect4 unreal plugin but other than that there’s no custom c++
  • I’m using 4.8.3 from the launcher. Nothing from github.

link text

link text

In the new rift template did you add the kinect plugin? Try adding this plugin and see if this is when the crash occurs.

Are there any significant differences between the blank project and yours? Do you have any different assets or any blueprints that you have added to the project?

Yes, the plugin is enabled in the new project and doesn’t seem to crash at all.

There is a significant difference in being that my project is fully complete. I have custom blueprints and assets but nothing extraordinary. I’ve been working on the project for about 6 weeks but it only started crashing in the last 3 days.

I found that deleting the DefaultEditor.ini and DefaultEngine.ini helped reduce the frequency of crashing. Maybe there was some corruption?

Possibly, have you tried moving a copy of the project to 4.9 to see if this particular crash has previously been addressed? Additionally, if you remove your content folders from the content browser, do you see the same crashes?

I did try migrating the content into the test blank project and still saw crashes. I wouldn’t be able to move the project from 4.8 to 4.9 due to the kinect4unreal plugin I’m using isn’t compatible with 4.9. Do you mean delete content folders when you say remove folders?

I didn’t have the nerve to move everything in my main project so I did what you asked in the test project and it crashed.

I wouldn’t recommend deleting, but if you go in your windows explorer to your project filepath and open the “content” folder, you can move all of the files out of the filepath to an empty folder outside of the project. If the crash still occurs it may be that your project has become corrupt, if not, it is safe to assume the problem is limited to your assets, and we can work backwards to limit which assets may actually be leading to the crash in question.

Can you send me the test project with your assets? I’ll be happy to take a look and see if I can reproduce this on my end.

Unfortunately I can’t share the project because of the NDA.

Do you have anything I can test or any steps I can take to reproduce this on my end? Unfortunately without further information there won’t be much I can do as it seems that this error is isolated to some specific assets from your project.

Hi Lobohotpants,

We have not heard from you in several days. I am marking this as answered for tracking purposes. IF you are still experiencing this error, please comment with the requested information.