Unknown error

I get an Unknown Error (RC’s words) when I try to build a model for my project. It’s a big project, with 1.8k photos and some 44 Laser Scans. I already aligned it without (seemingly) any issues, but it just stops inmediatly when try to calculate the model with normal or high detail. The issue does not occur with preview detail, but that’s not really usefull. I tried on a previous iteration of the same project, which has more or less similar inputs, and it works fine, but not the new one.

I’ve also tried to align it again, and then inmediatly trying to calculate the model. For a second it seemed like it was going to work, but it also stopped with “unknown error”

These are my current settings

Hi Key_Of_Void,
is it the same using not changed Reconstruction Settings?
Is it also happening after application reset (open RC with pushed SHIFT and choose the option Make it like a clean install)?
What are your PC’s parameters?

Not changed? You mean default settings? Yeah, I tried restoring it to default reconstruction settings, it didn’t work.

So, about that clean install. The thing is, my license is borrowed, so after the clean install i’m locked out of RC until my associate can give me the key again. On that topic, previously I tried to Repair my RC using the installer, however it would say this

image

My PC has a
image,
128GB RAM
And a
image

That repair error can be connected to this issue. And I would do the reinstallation of RC now, as there could be some issues with the application.
If you try other dataset is the model created? Or just images or laser scans?

I tried with a previous iteration of the same project, which had different photos but the same laser scan. That one still worked.

I’m still waiting for the key, so i’ll try again later.

So, even after the clean install, I still get the same Unkwnon Error

Hi, it seem like an issue with number of your cores. As you have 24 cores, you should have at least 192 GB RAM. Otherwise it is swapped on C disc.
Could you test disabling some of your cores or disabling hyperthreading in your BIOS? One more thing I would try is to manually set windows swap to 150% of your current RAM.

I don’t understand. The number of cores my cpu has should have no impact in my RAM. I could be wrong, tho. On that topic, I have no proper understanding of hyperthreading or any of the things you explained…


image


image

Hi, it is connected, but for AMD it is not called hyper threating.
Are you able to process other datasets or the data separately? Is it possible that you have overheating issue?
Is there something written in the console view when you get the error?
Also, you have quite big errors in your control points. Can you delete those red triangles or make it more precise?

In the end, I just started the alingment all over, using the same dataset but with GPS this time, and I was able to process a new model. Thank you for your asistance.

About the control points, no, I couldn’t delete the errors, although I didn’t need to. Those just indicate the difference when compared to two or more photos, so sometimes it’s helpful when an alignment is particulary bad.

This thread can be marked as resolved. (I don’t know how, tho)