Unknown cook failure (Android)

I followed the instructions on UE4 for building android games so I have set up the NVPACK and VS2017 as instructed.

But however I try to package the game it always fails with “UnknownCookFailure” (with no red or yellow error lines).
I tried reinstalling,running as admin and with various project settings.

The problem occurs even if I try to build the default “2Dside scroller”(mobile) game that is shipped with UE4 as a template.

Logs are attached below,thanks.

UAT log

saved log

Are you packaging with Gradle?

It appears you have not accepted SDK license according to this line -

[2017.11.26-21.15.37:658][799]PackagingResults: Error: License not accepted. SDK License must be accepted in the Android project settings to deploy your app to the device.

Also, have you tried deleting your build, intermediate and saved folder and package again? (Offcourse, make backups)

Try pacakging with SDK API lvl and NDK Level to “latest” without the quotes.

I tried both Gradle and Ant, accepted the license after I saw the error,and tried deleting those folders and migrating to a clean project. I will give a look at your last suggestion.

Tried setting levels to “latest” (was android-19) still nothing.
It must be something with plugins or SDK tools since I cant package default Android games.

Turns out I was unable to build only Android(ASTC). Once I removed ASTC from Android(multi) build inside Android project settings it worked fine.

Still not sure why ASTC is failling to build.

1 Like