Unknown cook Failure - a lot of UnknownFunction errors

Hey everyone, I wanted to package my project to give it a spin but I ran into a Cook failure which shows a lot of UnknownFunction[] errors, i will attach logs, but they go like this:

[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: begin: stack for UAT
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: === Critical error: ===
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error:
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: Assertion failed: NewPos > WriterPos [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\CoreUObject\Public\Serialization/BulkDataWriter.h] [Line: 40]
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error:
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error:
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error:
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: [Callstack] 0x00007ffd0c08a388 KERNELBASE.dll!UnknownFunction []
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: [Callstack] 0x00007ffcd0361f07 UE4Editor-Core.dll!UnknownFunction []
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: [Callstack] 0x00007ffcd03646b7 UE4Editor-Core.dll!UnknownFunction []
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: [Callstack] 0x00007ffcd0177cea UE4Editor-Core.dll!UnknownFunction []
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: [Callstack] 0x00007ffcd00ffe07 UE4Editor-Core.dll!UnknownFunction []
[2019.08.05-08.51.40:847][807]UATHelper: Packaging (Android (ETC1)):   LogWindows: Error: [Callstack] 0x00007ffcd0100499 UE4Editor-Core.dll!UnknownFunction []

I googled everywhere but I have no idea what might be the issue, someone suggested a blueprint error but i am not pointed towards any particular blueprint and someone said LODs but I tried removing all assets and it still failed.
Can I get help here?

log:link text

check this https://answers.unrealengine.com/questions/758236/all-my-plugins-nodes-get-call-unknown-function-err.html

It didn’t help or I may have interpreted his advice inproperly. Any other suggestion?

error LogWindows: Error: Assertion failed: NewPos > WriterPos:

for example empty lod Crashes on Import to UE4 -- Billboard bug? - SpeedTree Forum

It wasn’t really an LOD error and deleting folders didn’t help - I found the issue though. I had a stray camera blueprint that was for some reason crashing my engine so I deleted that .uasset and it worked fine - so a hint - clean your ■■■■ :smiley:

so to add to this topic, one of the problems that i had is corrupt blueprint. so im using the visual scripting version of ue4, and some of my problems happens because i made a function blueprint. inside that blueprints, i have some “world context object” pin that i didn’t plug. till this day, i never knew what to plug inside it. if you have those pins exposed, than delete that function and make it inside each actor. that pin really messed up my packaging.