Unknow Cook Failure when packaging for windows 64bit 4.13

I’m fairly new to UE4 so i apologize in advance if this is a rookie error but i can’t for the life of me troubleshoot this one myself and I would greatly appreciate any assistance in remedying this problem.

So i am working on an architectural visualization VR project for the htc vive and all has been going great, however when i try to package for windows 64bit i receive the error pasted below.

I have been looking around at similar issues and have tried resolving the issue by cloning the project, changing engine versions, creating blank projects and reimporting certain assets, i also noticed a thread about a similar issue that referred to the substance plugin causing issues but i have disabled that also now, along with all other plugins that weren’t required, but to no avail.
I should note however that I am able to compile other, unrelated projects in the same engine version without any issues.

Attached are the UAT_Log, Cook log and my full Output Log saved as a text file, if any other files are required for troubleshooting please let me know and i’ll attach them.

Thanks in advance,
Blair

Below is the last chunk of my output log.

UATHelper: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.09.11-23.46.08:268][ 0]LogOnline:Display: Unloading online subsystem: NULL
UATHelper: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 34.596604s to run UE4Editor-Cmd.exe, ExitCode=1
UATHelper: Packaging (Windows (64-bit)): Project.Cook: Cook failed. Deleting cooked data.
UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Cook failed. —> AutomationTool.AutomationException: BUILD FAILED: Failed while running Cook for C:\Users\Blair\Documents\Unreal Projects\IntAptfix\IntAptfix.uproject; see log C:\Users\Blair\AppData\Roaming\Unreal Engin
e\AutomationTool\Logs\C+Program+Files+(x86)+Epic+Games+4.13\Cook-2016.09.12-09.46.08.txt
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.RunCommandlet(FileReference ProjectName, String UE4Exe, String Commandlet, String Parameters)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.CommandUtils.CookCommandlet(FileReference ProjectName, String UE4Exe, String[] Maps, String[] Dirs, String InternationalizationPreset, String[] CulturesToCook, String TargetPlatform, String Parameters)
UATHelper: Packaging (Windows (64-bit)): at Project.Cook(ProjectParams Params)
UATHelper: Packaging (Windows (64-bit)): — End of inner exception stack trace —
UATHelper: Packaging (Windows (64-bit)): at Project.Cook(ProjectParams Params)
UATHelper: Packaging (Windows (64-bit)): at BuildCookRun.DoBuildCookRun(ProjectParams Params)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.BuildCommand.Execute()
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Automation.Process(String[] Arguments)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.MainProc(Object Param)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
UATHelper: Packaging (Windows (64-bit)): at AutomationTool.Program.Main()
UATHelper: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=25 (Error_UnknownCookFailure)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults:Error: Error Unknown Cook Failure

Hi BlairCW,

I believe a some the steps you tried in troubleshooting have compounded the issue some… When examining the logs yourself, use Ctrl + F to bring up the “Find” menu and search “Summary.” The errors listed here are generally what is causing packaging to fail (Although sometimes there’s more, this is where you want to start.)

Looking at your Output Logs…

We see

[2016.09.11-23.46.07:469][  0]LogInit:Display: Warning/Error Summary (Unique only)
[2016.09.11-23.46.07:469][  0]LogInit:Display: -----------------------------------
[2016.09.11-23.46.07:470][  0]LogInit:Display: LogBlueprint:Error: [Compiler WebBrowser] Error Could not find a function named "LoadURL" in 'WebBrowser'.
Make sure 'WebBrowser' has been compiled for  K2Node_CallFunction_3375 from Source: /Game/ExampleContent/VR_Trace_Interaction/Blueprints/Widgets/WebBrowser.WebBrowser
[2016.09.11-23.46.07:470][  0]LogInit:Display: LogBlueprint:Error: [Compiler WebBrowser] Error The property associated with  WebBrowser_0  could not be found from Source: /Game/ExampleContent/VR_Trace_Interaction/Blueprints/Widgets/WebBrowser.WebBrowser
[2016.09.11-23.46.07:470][  0]LogInit:Display: LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty /Game/Blueprints/FunctionLibraries/VRFunctionLibrary.VRFunctionLibrary_C:GetHeadsetType.CallFunc_GetUserProfile_Profile'. Unknown structure.
[2016.09.11-23.46.07:470][  0]LogInit:Display: LogBlueprint:Error: [Compiler VRFunctionLibrary] Error This blueprint (self) is not compatible with ' self ', therefore that pin must have a connection. from Source: /Game/Blueprints/FunctionLibraries/VRFunctionLibrary.VRFunctionLibrary
[2016.09.11-23.46.07:470][  0]LogInit:Display: LogBlueprint:Error: [Compiler VRFunctionLibrary] Error Could not find a function named "GetUserProfile" in 'VRFunctionLibrary'.
Make sure 'VRFunctionLibrary' has been compiled for  K2Node_CallFunction_2951 from Source: /Game/Blueprints/FunctionLibraries/VRFunctionLibrary.VRFunctionLibrary
[2016.09.11-23.46.07:471][  0]LogInit:Display: LogBlueprint:Error: [Compiler VRFunctionLibrary] Error Failed to create property CallFunc_GetUserProfile_Profile from  <None>  due to a bad or unknown type (Structure) from Source: 

These errors will need to be corrected in order to successfully package to Windows 64.

Additionally you had a number of other errors that, as I mentioned before, were likely caused by cloning your project etc. resulting in assets being listed as not found. To correct these:

  1. Open each level and run a map check; correct errors for each level
  2. Right Click on the Contents folder in the Content Browser and select “fix up redirectors in folder”
  3. Delete the Intermediate and Saved folders from the project folder
  4. Re-Save the project

-Steve H.

Thanks heaps for that Steve, really appreciate the help!

I’ll give all that a go now, and keep it in mind for future mistakes to avoid having the same issue again!

This worked perfectly for me after trying so many other things. Thank you Steve