Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000018 when opening or even right clicking level


I’ve been working on a user interface and loaded a different level (double click). I skipped some files I didn’t want to save and did some minor things in the other map. Then I closed the whole editor and took a break. After I started the editor again, I couldn’t open my main level anymore (See the attached ** Log File ** )

I could manage to migrate the whole level to another project (also crashes there) and then I could indeed open the level in the old project one last time. I saved it again and now it keeps crashing when I try to open it (double click) as well as when I just right click (to do maybe another migration)

My whole master’s thesis depends on this and I really need that state as I only have about 2 weeks left to do all the programming.

Altough the log files (the other log file is from the backup project) show different entries before the LogCrashTracker line, it’s always the Exception_Access_Violation reading address 0x00000018 error.

Is there anything I can do to recover the state?

Kind Regards and Thank you,


1 Like

Found out, that, if I open all blueprints I recently worked on, before I open the level, the level doesn’t crash, but how do I fix this behaviour?

Okay, most of my created actors and blueprints crash the editor, if I try to open them by double click. The editor then crashes with the same error. However, if I open some certain blueprints before I open other things (including the level) it just works. Is it an editor bug or is it something on my end? Also, what does a red connection in the reference viewer mean?

Okay, I saw my post has been moved to the Bug Reports section. I’m not sure, though, whether it is a bug at all. Still don’t know if I’m doing something wrong in my blueprints and, more important, what caused the issue… is there any information on this topic available?

Hey Markus-

It sounds as though the level is trying to reference something that it doesn’t have access to when loading. You mentioned making changes to an interface, if your level blueprint uses or makes reference to this interface, I would try to revert any changes to before this began. Additionally, please ensure that all blueprints, especially those that are used in the level, are compiled. Also, please check the comment from Matthew Clark from the 16th in this link. This should hopefully allow you to open the level and check the level blueprint to see if there are any references being made that aren’t valid. Please let me know if this is helpful. If possible, please also include the full callstack and log files from the crash for additional information.

Well, the user interface should just display some images and it was right after adding it when I discovered the problem. I also tried to revert the changes but it didn’t solve the problem, so I assume, something went wrong at some point since christmas. I’ve been working on the whole project for several days without closing the editor or changing the level, though. I was working on a big part of the game and I haven’t committed any non-working stage :-/ So reverting the project to a certain point isn’t that easy.

I could revert the whole project to the stage and put in minor parts of the current state back into it, but that requires some time (maybe I find some time for this on the next weekend).

In the meantime I could open the level again by opening some blueprints (right now it’s the game mode and the player controller) before I open the level and then it works. But that solution also requires some luck as the blueprints I have to open to make it work again varies (and I haven’t found any pattern yet), so sometimes I have to open the editor several times until it loads the level successfully.

I’ll also try, if your link will solve the problem.

I really don’t have any clue about what’s going on with the editor right now and I also really don’t know yet how to explain that behaviour to my professor, haha

Thanks for your answer :slight_smile: I’ll get back to you as soon as I know more

Hi, I’ve updated now to Engine Version 4.14.2 and the level still crashes if I don’t open some blueprints before (this time I just had to open my game mode blueprint). The log, however, showed this outputs:

Do you think those warnings could cause the problem? How come they end up with no world context?

Judging by the warning messages, it appears the level is trying to destroy some actors before the level has actually loaded those actors. If possible, could you provide a copy of your project to help me investigate the issue locally? If you’re able to upload the project to google drive or something similar, you can post a download link here, or send me a PM on the forums for privacy.

ya, that would be great. I’ll send you a PM along with my email address if you should have any further questions when I’ve uploaded it. It could get a bit large, though

When packing the project for you, I stumbled across those errors in the output log:

The listed bow asset exists at least under a different location on the disk. Is it possible that missing assets can cause the editor to crash? If so, how likely is it that offered asset packages in the store are broken? And is there a way to tell which blueprint is referencing those assets? Anyways, I’ll send you a minimum project with the broken map (it’s uploading right now)


Thank you for the sample project. I was able to isolate the crash to a “Get Game Mode → Cast to CDGameMode” call in your FrontGate Blueprint (specifically the OnRep_Health function). Seeing as the crash is an access violation, it appears that it is trying to the game mode before it has been loaded which is causing the issue. This is also why opening the blueprint, which causes the editor to recognize the game mode, prevents the crash from occurring. Additionally, if you set the game mode for your editor starting level to the CDGameMode blueprint, this will load the blueprint when the editor is launched and prevent the crash when opening your specific level.


Awesome, thank you so much!

I’ve changed the level now, so the FrontGate will be added to the level by the GameMode itself and the level starts again. I couldn’t set the GameMode directly in my starting level as it has it’s own GameMode, so it’s working now.

Thank you very much for your help! :slight_smile:


could you tell me please how you isolated the problem? Seems like I’ve run into the same problem again, but I was essentially just adding sound

Thank you

never mind… dunno why, but it’s working again…

Since you mentioned Opening the GameMode blueprint allowed the level to open, I went looking through blueprints in that level with references to the game mode. From there it was trial and error of disconnecting references until I located the one that was acting as the blocker. If you have the same issue of opening your GameMode blueprint (or any blueprint) temporarily solves the issue, I would try finding references to that blueprint and removing them one at a time.

Hey, thank you for the explanation. I’ve tried to package everything today and it fails with the same error. However, I can open all levels etc. in the editor. The log file isn’t giving any further information. It’s no big deal right now, as I got the editor as backup, but is there a strategy to debug within the package tool?

Also, could you please create a feature request or something to add a little more output to the log files? The sole line “Unhandled Exception: EXCEPTION_ACCESS…” makes it really difficult to debug it without assistance, so I really appreciate your help :slight_smile:

Can you post the full output from the package logs?


ya, here yo go:



Also, I’ve found another post with pretty much the same error message but it seems to be caused by something different (which doesn’t mean, I know what’s causing my problem, haha)

Since the other issue you linked mentioned being tied to a specific map, and your project was having problems with opening your map, I would try removing that map from the project temporarily to see if you can package. I also noticed, looking at your logs, that a number of assets couldn’t be saved because the filename was too long. I would try shortening folder names and/or moving assets so that you don’t have more than three to five nested folders. If you are still having issues with packaging, it would probably be best to create a new post since the issue is not directly related to what was originally being reported (the level not being able to open).

Hey, ya, I’ve tried it and I could narrow the problem down to the same level. I’ve opened a new post here: Exception_Access_Violation reading address 0x00000018 when packaging game - Blueprint - Unreal Engine Forums

1 Like