Download

Undo hotfix 4.11.1 to try using the 0.8.0 oculus runtime

Hello,

I am working on a vr project on the UE4.11.1 but the oculus is not working (it was in 4.10.4).

I’ve installed the latest oculus runtime (1.3.1) but the setup stops at “update your graphic card” step.
I have a quadro k2200 graphic card (don’t blame me, it’s at my working place) so I cannot finish setting up the dk2 since it’s waiting for a GTX driver to be installed.
I guess this is the reason why the UE4 don’t launch the game in the oculus even if the play on vr button is available (plus, the oculus led is orange and the camera is not on).

I had the 0.8.0 oculus runtime and it’s demo was working so the quadro can handle it, the problem was that it was not working on UE4.11.1 (the play on vr button was not clickable).

I really need the UE4.11 since we are using the leap motion and in older versions of UE the plug-in wasn’t official.
I’ve looked in forums and I understood that in UE4.11.0 the oculus runtime 0.8.0 works (but I’m not sure).

So I wanted to try undoing the hotfix and going back to UE4.11.0, is it possible ? (it’s not showing as option in the download other versions).

I’m having the same problem. 4.11.1 completely removed support for 0.8.0, which was the only thing my DK2 could handle.
As far as I know, the only way to go back to 4.11 is by building it from the source from github.

It is quite appalling though that Epic wouldn’t let us know that they would be dropping support for pretty much all oculus devkits that aren’t running 1.3.0. Or at least I hope that it is a bug and they’ll patch it up soon.

I had a similar issue but you cannot undo a hotfix binary release. Only if you build it from the source yourself.

If you uninstall the Oculus SDK 0.8 and install the Oculus Home application (which includes the new 1.3 SDK ), you can still use your DK2 in UE4. You do have to upgrade older projects and re-package to make them work with the new SDK.

I also hope it is a bug and that the 0.8 support will come back, but I cannot afford to wait and see :confused:
Thanks for your reply, I’ll try building the 4.11 from source and see if it works.

Does anyone has managed to get oculus dk2 work with 4.11 or later version of UE4 with 0.8.0 runtime ? I am also having the similar issue where in ‘VR-Preview’ button is enable(sometimes it gets grayed out, dont know why) but still project is not launched in dk2.