"Undo" deselects current emitter

Hi all, I’m trying to just “undo” (ctrl+z) while working, but every time I do, Unreal deselects the current emitter I’m. on so I have to re-click the emitter to keep working.

Is there some setting so this doesn’t happen?

I’m on 4.25.3

Am inside the Niagara System, and am just trying to undo a value I may have gone overboard with. “Undo” does work (the values revert back), but I do have to re-click the emitter I was on to continue working.

Any help’s appreciated! Thanks