Underwater post process only inside circle

When I go underwater the post process effects only appear inside a circle.
How can I make the effects cover the whole screen?
(I am using 5.0.1)

2 Likes

Did you ever find a solution? I liked and followed your post months ago but I still haven’t found a workaround (and it’s not fixed in 5.0.3)

Greetings Ares9323, thank you for asking the original poster if they found a solution.

I took a gander as well at the ocean actor in my level and found that the Collison Extents of the WaterBodyOcean actor can be adjusted. Have you already tried this solution?

I hope this helps.

1 Like

Thank you for your answer, I tried it with high hopes as soon as I woke up but, unfortunately, changing the collision extents only resizes a box and does not affect that circle, I think it’s something related to the camera:

To reproduce you need a preview window that is FHD or larger, it doesn’t happen with smaller resolutions because it’s cropped (and the fact that is not centered to the camera is misleading me)

Thank you for the reply with those great repro steps!

I see what you mean now. I went and adjusted the camera’s FOV and it made a difference for the better. Have you already tried adjusting the FOV? I am not sure why we can see that visual effect but I will keep looking into it too.

I hope this gives us a clue to where we can solve this.

1 Like

Sorry for the late answer but this week I’ve been really busy for the MegaJam and in the end I had to remove the water plugin from the project and use two planes and a post process volume.

However I’m interested in solving this issue, I tried adjusting the FOV but it’s not a real solution, also because it happens in the editor and not only during the game.

I’m trying to compare the ue4 version with the ue5 version but I didn’t find any significant difference

This is a not so old bug that hasn’t been resolved (I was the one who reported it). Supposed to be fixed for 5.1, but ended up backlogged.

Basically this happens if you use temporal upscaling and the screen percentage is lower than 100%

3 Likes

I had this problem and thought it related to the post processing volume being smaller than the spline it’s attached to (I’m a newb so…) i.e. the dry land was larger than the PPV in my case creating an ocean around a large island.
After several attempts to figure out a work around and getting very close (by placing the ocean near to where I want the only accessible beach, then dragging the spline out to the other land edges, leaving the PPV by the beach), I still had the circular edge of the PP effect as shown in the OP (on the right).
Very frustrating, but in looking around to where the issue would show up, I noticed some distant objects being post processed in the otherwise unprocessed area thinking
I didn’t have a skybox/sphere, so added one, and it’s fixed :slight_smile:
Leaving this here to add to the conversation in order to help build a picture of what’s going on; not attempting to answer or solve the problem (I’m a newb after all).

close temporal upscaling,than get well. :smile:

Thanks so much @Ichinose ! And WOW… I PRAISE GOD for guiding me to solve this!!!

Until you mentioned it, I didn’t realize that Temporal Upsampling also had played a role in addition to a low screen percentage. But thanks to this post on Reddit, we now have a VERY simple fix!

    1. Select your Water Body, and in the Details panel, scroll down to the Rendering section. Click the “Folder/Magnifying Glass” icon to automatically browse to the material “M_UnderWater_PostProcess_Volume”. Double click to open it.
    1. Inside the material, click in an empty area of the graph. Now go to the Details panel and type Blendable in the search field.
    1. Under “Blendable Location” change it from “After Tonemapping” to “Before Tonemapping” (you can also select “Before Translucency”, but I found it to make no difference).

image

    1. Your waterline will now work correctly, even with Temporal Upsampling enabled!! However, it will look a little bit different (slightly lighter). If you don’t like this, then right click on your “M_UnderWater_PostProcess_Volume” material and create a new Material Instance. Now assign this new Material Instance to your Water Body in the Underwater Post Process Material slot as shown below:

    1. Lastly, open your Material Instance, enable the box for “Band Offset”, and play with this value. I found changing the value from 0.5 to 0.1 closely resembled the original waterline look. I hope this helps! :grin: