Unchecking CastShadow still bakes static shadow

We are using low-poly static meshes that are hidden in game for collision in some cases. We are noticing that Lightmass is still mapping shadows for these meshes even with CastShadow disabled. I’ve checked the code in SetupStaticLighting…and it appears CastShadow is never checked when adding meshes/actors/components to the processing list. I see that its checked but commented out for BSP geometry. I was able to add some code in there myself but wanted to know what the intended behavior/code path is here. We are trying to avoid building tons of UCX collision by just using our lowest poly LOD for collision with complex as simple set. Unfortunately these meshes are taking up valuable build time and lightmap texture space!

Any help would be appreciated.


Try to uncheck the render in Main Pass check box, this should remove the mesh from the lightmap build pass completely, but allow you to keep the collision aspect of the mesh.

Thank You -

Eric Ketchum