Unable to view details of inherited mesh of c++

Hey all,

So I’m working on this FPS game and I have a c++ file called mannequin.cpp of type Character.

I’ve got a new character which my friend created, its parent class is of type character so switching over to mannequin.cpp shouldn’t be a problem, and it compiles fine, but when I run the game it crashes.

The issue I think is one of the inherited meshes from the C++ source file does not display the mesh detail for some odd reason. I’ve left screen shots below I’d appreciate any help.

You need to put EditAnywhere specifier on component pointer to make it editable in blueprints

It was originally set to VisibleDefaultsOnly I’ve changed that to EditAnywhere, I still get the same issue thought. One character works fine, the new imported one doesn’t seem to want to display anything on the details tab

hey I removed the code and added it again then recompiled then it somehow magically worked. Didn’t need to change anything. Thanks for the help