Unable to spawn instances. Ensure a large enough surface exists within the volume

Currently working with a level streaming tiled Terrain. As I attempt to populate the terrain with Trees and other procedural generated assets, I get this error message. Unable to spawn instances. Ensure a large enough surface exists within the volume.

This happens once I hit Resimulate in the Procedural Foliage section of UE4.

Did you find a fix for this already? I am encountering the same problem. As a test I converted my landscape to a static mesh and it only had an approx size of 1x1x0. It seems the engine sees this huge landscape as something very tiny. So tiny in fact that there is no room for even one tree or bush to place on it.

Did you find a solution. Also having same issue.

I didn’t find a fix for the spawner but I was eventually able to paint foliage on my landscape by hand. I didn’t change anything so I’m not sure why that suddenly worked as it didn’t before. I’m still interested in a fix for the spawner.

Interestingly, it looks like my issue with the spawner relates to secondary levels. My initial level works fine but nothing on my second level.

If you find it isn’t working on your initial level then something I read about was going into edit on the spawner, double clicking on your foliage type actor, then checking the ‘Height’ Min and Max to ensure it’s within appropriate range. In my case my foliage seems to be min -262144.0 and max 262144.0 which certainly more than covers the range I need.

I found that could get rid of the “Unable to spawn instances. Ensure a large enough surface exists within the volume.” message by making the spawn area twice the size that I needed it, though nothing got generated on the second level.

Are you working on a single level or multiple as part of a tiled terrain?

I may have found a solution to this, at least for single levels anyway. First off, make sure the spawn actor is twice the size that you need to make the surface area error message go away. Secondly check that your level is at position 0,0 in world composition editor. I found that I could spawn trees on a single level whilst the level was at position 0,0. The moment I moved the level slightly off centre of the world, the trees would no longer spawn. If this works for you great, it certainly isn’t an answer as to what is going off and how to properly fix, but it does at least seem to be step forward in identifying the area of the problem if we indeed do both have the same issue.

Further trial and error with the spawner I was using showed that if I created my levels, then impoterd heightmaps for each then the spawner would not work on any of the levels other than the first. Even then, if I shifted the x or y location of the first level it would stop working. However, I found that if I created my new levels via import tled levels and imported all my png heightmaps that way, then the spawner seemed to work absolutely fine, even if I moved the x or y locations of the levels. Hope this helps you.

I am having this same issue

Uploaded video here: - YouTube

I can spawn the trees on BSP geometry and also on a static mesh

But I cannot spawn trees on the most important thing: Landscapes

So in the video one terrain lets me paint rocks on it while the other does not which is also very strange. They are exactly the same terrain.

But the main issue is that none of my terrains allow any trees to spawn when I hit “resimulate” in the details of the spawner volumes.

When “resimulate” is hit it give the error: Unable to spawn instances. Ensure a large enough surface exists within the volume.

Have you solved the problem ?

In your Foliage type is needed define Landscape layer…, It is one of the most issues, but this one is important, if you every time use another layers

1 Like

Worked for me. Thank you Hargreawe!!

Probably your foliage type objects are too big to spawn. You need to get them smaller or make procedural foliage spawner bigger.

So, I was having the same problem and couldn’t figure out what was wrong. Then I checked each and every setting and found that if I set my Z-offset to negative I get this error. I reverted back to the default value that is 0 and works perfectly fine.

had the same issue with a duplicate volume, turns out I had a blocking volume in it
stupid of me

Hey, this might have come a bit late. The thing that helped me was resetting the “inclusion landscape layer” and getting rid of the array element. My issue was caused by a foliage asset pack trying to only spawn on a landscape layer that wasn’t actually on my landscape. The error message didnt help with trying to figure this out either. The mawi redwood foliage assets wouldn’t spawn onto my brushify landscape until i fixed that. Furthermore this youtube link will show you the exact setting that i changed.

23:00 is the timestamp.


Check to make sure your Foliage Type actors don’t have a landscape layer specified. If they do, you can Bulk Edit and delete the specified landscape layer and this will enable them to spawn on any landscape material.

1 Like

Hello , Like everyone else I had the same issue.

Select all Foliage in the Foliage Tool and Delete these Array elements on the Inclusion / Exclusion Landscape Layers . Then the PF Tool and Paint will work…

1 Like

I find a solution just replace the foliage type or create a new one


This is it, I downloaded some trees from a pack but could place them in my scene procedurally. Turns out that those trees were using landscape layers.

1 Like

Enlarge the box along the Z-axis and check for any vertices that may be too close together. Additionally, it’s crucial to keep the pivot point near the landscape. While the scale of the asset is a consideration, other factors, such as vertex spacing and pivot placement, are equally important